Author Topic: LS220D Fan / Debian question  (Read 1517 times)

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #15 on: July 14, 2019, 01:45:21 am »
uImage.buffalo.ls220d - C76D2BFF42E942B453722F749C517724
initrd.buffalo - 0EFF3BF6BC8418300E18A2FCAAFC9B99

I decided to connect the LS220D LAN cable directly to my PC NIC, set an IP for my NIC.  Linkstation was recognised when I input the Linkstation IP address 192.168.0.34 into my browser and it takes me to the Linkstation settings page, but still the same error message ssh: connect to host 192.168.0.34 port 22: Connection refused

So it must be something to do with my PC and nothing to do with the Superhub 3.

Just to check that the command is ssh installer@192.168.0.34 I dont have to put anything else in like Admin hostname password etc.

Thanks.

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #16 on: July 14, 2019, 02:29:57 am »
uImage.buffalo.ls220d - C76D2BFF42E942B453722F749C517724
initrd.buffalo - 0EFF3BF6BC8418300E18A2FCAAFC9B99

I decided to connect the LS220D LAN cable directly to my PC NIC, set an IP for my NIC.  Linkstation was recognised when I input the Linkstation IP address 192.168.0.34 into my browser and it takes me to the Linkstation settings page, but still the same error message ssh: connect to host 192.168.0.34 port 22: Connection refused

So it must be something to do with my PC and nothing to do with the Superhub 3.

Just to check that the command is ssh installer@192.168.0.34 I dont have to put anything else in like Admin hostname password etc.

I tried using a program called ACP Commander GUI for Windows and it connects to the LS220D using Enable SSH on port 22936 and it seems to recognise it, but if I change it to port 22 then it does not, so I may need to change the SSH config for port 22936 on ubuntu sshd config.

https://nerdkey.co.uk/guides/enable-ssh-linkstation-stock-firmware/

BTW - Im on V1.70 FW


Thanks.

oxygen8

  • The Oxy-genuine article
  • El Toro
  • ****
  • Posts: 362
  • Giving you some breathing space.
Re: LS220D Fan / Debian question
« Reply #17 on: July 14, 2019, 03:39:59 am »
Open SSH
https://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/ssh-freischalten-auf-einer-ls210d-t2408.html

Do NOT use the ssh command from Windows 10. The LS is to old.
Use Putty.

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #18 on: July 14, 2019, 05:35:37 am »
Oxygen8 Iíve ran the commands that you linked too with my settings and now I run putty with the ip and itís connects which it would not before


I enter admin and nas password and now when I do ssh using putty in Ubuntu it now actually does something instead of refusing to connect,

Is ssh installer@ip the command to actually install the Debian FW or should it install once it reboots I already have the two files sitting in the boot dir or do I run another command instead.

« Last Edit: July 14, 2019, 06:49:32 am by GMAN73 »

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #19 on: July 14, 2019, 08:13:00 am »
I checked those hashes against mine and they are correct. This must be really close to working.

Could you try again and post your full terminal output from the attempt? If youíre missing a step or something we should be able to spot it that way.

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #20 on: July 14, 2019, 08:39:43 am »
Hey there,

I did a video of what ive done right up until I use the reboot command and wait 5 mins.

See the playlist on youtube.

https://www.youtube.com/playlist?list=PLGFsAkG6spGE8QFDzmaHtHuKFB7Xl2su4


java -jar acp_commander_cli.jar -f

java -jar acp_commander_cli.jar -t 192.168.0.34 -ip 192.168.0.34 -pw password -c "/bin/busybox telnetd&"

java -jar acp_commander_cli.jar -t 192.168.0.34 -ip 192.168.0.34 -pw password -c "chmod -R 777 /boot"

cd ..
cd /gman/             
python -m SimpleHTTPServer 8000 >/dev/null 2>&1 &cd /boot
[1] 31817
telnet 192.168.0.34
Trying 192.168.0.34...
Connected to ls220de.
Escape character is '^]'.

BUFFALO INC. LinkStation series
LS220DED26 login: admin
Password:
[admin@LS220DED26 ~]$ cd /boot
[admin@LS220DED26 boot]$ mv uImage.buffalo uImage.buffalo.bak
[admin@LS220DED26 boot]$ mv initrd.buffalo initrd.buffalo.bak

wget http://192.168.0.34:9000/axs/u:dfed1e5c82defa6fd5aa78953443df73/initrd.buffalo

wget http://192.168.0.34:9000/axs/u:0303b00b7e5690a30a2b35d36ce56cc9/uImage.buffalo.ls220d

[admin@LS220DED26 boot]$ mv uImage.buffalo.ls220d uImage.buffalo       
[admin@LS220DED26 boot]$ sync
[admin@LS220DED26 boot]$ exit
logout
Connection closed by foreign host.

$ java -jar acp_commander_cli.jar -t 192.168.0.34 -ip 192.168.0.34 -pw password -c "reboot"
« Last Edit: July 14, 2019, 08:56:44 am by GMAN73 »

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #21 on: July 14, 2019, 09:06:54 am »
okay, I think I see the problem now.... possibly.

change your wget to pull from the python http server you started rather than from the copy you put on the nas share.

it should be:
wget http://<ip of your desktop>:9000/initrd.buffalo
etc.

I don't see specifically why your method wouldn't work but I'd like to try it the other way to be sure.


GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian ques
« Reply #22 on: July 14, 2019, 11:43:03 am »
I get a connection error when doing wget myipaddress this must involve configuring wget to pull files from my folder on my PC which I donít know how to do.  :(

Anyway I pulled the two files over did sync and then ls to list folder to make sure they were sitting there with the buffalo bak files, they were I used the reboot command and it rebooted well no Debian showing in the webpage for the NAS, did all the commands again up until I got into the boot folder and the 4 files were still there 2 buffalo and the 2 bak.  So itís not booting them for some reason. 

I switched it off and I took out the 2TB HDD in bay 2  and turned it back on did all the commands again and I notice that in the boot folder the 2 bak files are not there so that got me thinking has the boot folder Iíve been seeing been for the 2TB in bay 2 and not the 3TB in bay 1.

So Iíve done all the commands again and transferred the files over and done the reboot command.  It started flashing for a minute and now itís just staying white with no hdd loading, getting page not displayed when using the IP address in the browser and itís recognising it in my router devices by its MAC address and not the name of the device, so think itís start to call it a day.

Thanks for all your advice  everyone 

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #23 on: July 14, 2019, 12:26:07 pm »
That sounds like the behavior you should see if itís working.

Try connecting via ssh again (ssh installer@<ip address>)

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #24 on: July 14, 2019, 01:10:17 pm »
Hey 1000001101000

So I decided to test it with a fresh HDD that I have spare.

Done all the usual commands, transfered the files, done sync, done ls to make sure the files are loaded on cd /boot of the LS220d.

gman@gman-XPS-8300:~$ ssh installer@192.168.0.11
The authenticity of host '192.168.0.11 (192.168.0.11)' can't be established.
RSA key fingerprint is SHA256:vst+Dz12epdYOkHfyEhRe6kvtaFO47yJCwN+TowIr5s.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.11' (RSA) to the list of known hosts.
installer@192.168.0.11's password:
Permission denied, please try again.
installer@192.168.0.11's password:

So when I do ssh@192.168.0.11 its asking for a password which I dont know how can I find out the password, this is the bit thats always puzzling me the password, when you did ssh@yourip what password did you put it, your user password for your linux logon, your NAS password or a password that you created for this , this password bit has been a stumbling block for me.

Update - The password is install so now going to attempt install.  :) :) :) :) :) :)
« Last Edit: July 14, 2019, 01:54:25 pm by GMAN73 »

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #25 on: July 14, 2019, 01:53:02 pm »
Excellent! You can go back to the github instructions from this point.

The username is installer and the password is install

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #26 on: July 14, 2019, 01:55:48 pm »
Wow cannot believe ive got this far, so many options to chose from.  Its confusing, but will see how it goes.

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #27 on: July 14, 2019, 02:18:31 pm »
Awesome.

Just remember the first partition/array needs to be formatted ext3 and mounted as /boot

If youíd like, take a screenshot of the partition screen before you save your changes and I can verify if it looks ok.

GMAN73

  • Calf
  • *
  • Posts: 22
Re: LS220D Fan / Debian question
« Reply #28 on: July 14, 2019, 02:31:03 pm »
Hi 1000001101000,

So 1st partition set to ext 3 and mount is set to /boot also selected format, though itís came up about root file system which partition mount is set to /

If you donít use raid take it you just use the scsi disks further down.

Thanks
« Last Edit: July 14, 2019, 03:36:34 pm by GMAN73 »

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS220D Fan / Debian question
« Reply #29 on: July 14, 2019, 03:46:27 pm »
You can do it either way, though if you donít use raid you should delete the arrays first.

You can use the first array as /boot as long as itís formatted ext3