Buffalo Forums

Products => Storage => : mpkadz January 18, 2021, 08:07:15 AM

: Re-using Drives questions
: mpkadz January 18, 2021, 08:07:15 AM
I recently took over IT Support at our church.  We have an old TeraStation TS-WVH2.0TL/R1 (s/n 95835211100026) - that I would like to replace, but have basically no budget.  I was given a TS5400D0804 (s/n 99877120700011) with no drives in it.  The TS5400 appears to be a much newer unit, so I removed the two drives from the old unit and put them in the TS5400.  It boots up fine, but still when accessing it, it still thinks it is the TS-WVH, with the old units name, serial number, firmware, etc. and all of my data. Basically it looks looks like I am still on the old unit.  Is there a way to update the drives to be recognized as a newer unit so I can utilize newer firmware, security, etc.?  I have all the data backed up, so I am not worried about losing it.

Also, the old drive had only two drives, and the TS5400 has 4 bays, but I only had 2 drives from the old unit to put in.  The display is red, so is this an issue and is this setup gong to work?

Any help is appreciated.  Thanks in advance.
: Re: Re-using Drives questions
: 1000001101000 January 18, 2021, 11:07:33 AM
If you are not concerned about saving the data it will be much easier to start with blank drives.

Buffalo provides a recovery disk image for this model you can get along with the firmware updater on the support page. You should be able to perform a fresh install using that and the firmware updater in "debug" mode.

The process is basically the same as this, only you use the recovery disk to get to EM mode and then proceed from there:

For some reason these devices don't like to install the firmware unless all drive bays are filled. Some also incorrectly see 2-bay devices as 4-bay devices which can further complicate things in some cases. The guide I linked above includes a method for installing to 2 drives if you run into that issue.
: Re: Re-using Drives questions
: mpkadz January 19, 2021, 06:30:48 AM
Thanks, I'll try it and post the results.
: Re: Re-using Drives questions
: mpkadz January 19, 2021, 08:54:56 AM
FYI, I will be doing this from a Windows10 computer because I do not have access to a LINUX machine.
: Re: Re-using Drives questions
: mpkadz January 22, 2021, 03:40:22 PM
The TS5400 would not work with just the two drives I had in the old unit (the two 1 Tb drives from the TS-WVHL), so I had to find two additional 1 Tb drives to fill all four bays. I tried several spare drives, but even though I wiped them as I was instructed, I could not get them to work, which I figured was because they weren't matching drives. I had 3 Seagates, a WD and a Samsung. I then found 4 nearly identical 500 Gb Seagate drives that ended up working!

This process is what worked for me, courtesy of James L., Technical Support Associate, Buffalo Americas.

Once the drives are deemed healthy, erase all data stored on the drive using the following command named Disk Part, instructions are on the following link: https://www.buffalotech.com/knowledge-base/cleaning-a-disk-in-windows-7-using-diskpart.  Then once the drives are erased, reinsert the blank unformatted drives back into the TeraStation 5400 chassis. DO NOT FORMAT THE DRIVES AFTER ERASING THEM, THIS WILL CAUSE ISSUES WITH THE TERASTATION AND LOCATING THE DRIVES.  Next step is to load the TeraStation 5000 series firmware image onto a USB flash drive, instructions on how to do this are on the following walkthrough: https://www.buffalotech.com/knowledge-base/creating-a-terastation-5000-recover-key-from-a-downloaded-image .  Recovery Image is under Utilities, labeled (Bootable USB recovery image for TS5000 series) Please make sure the USB flash drive you use to load the image is at least 4GB in size, and does not have any other data on it. Once you load the Recovery image onto the USB flash drive, insert the flash drive into a USB 2.0 port on the TeraStation, and set the Boot selector switch on the back of the TeraStation to (USB) then turn the TeraStation on afterward. The recovery process should be automated from this point on, after the recovery has finished, which should take 30-45 minutes, remove the USB flash drive, and set the boot selector switch back to (Hard drive/HDD) and reboot the TeraStation. You should be able to access the TeraStation from this point on for configuration, Use NAS Navigator 2 to search for the TeraStation if you are having trouble finding it. You can find NAS Navigatgor 2: https://www.buffalotech.com/support/

 Thanks everyone! We are back up and running.