Buffalo Forums

Products => Storage => : bleedish August 15, 2019, 02:50:15 PM

: TS-X4.0TL/R5 LCD display not working
: bleedish August 15, 2019, 02:50:15 PM
I had to restore factory defaults to my TS-X4.0TL/R5.  I powered on the unit and held down the reset button for five seconds per the manual.
After doing this the unit was in EM mode.  I had to reinstall the firmware to get the unit functioning again.  After the unit came back up the LCD no longer works.  I get no information on it.  It is lit up blue all the time with nothing on the screen.  It was working fine before the reset. 

Anyone have anything similar happen.  I've tried resetting the unit and reinstalling the firmware several times but it just won't work any more.  I've also tried older firmware versions and those don't work either.  I'm at a loss and Buffalo support has no idea what to do either.  It's driving me nuts cause it was working just before resetting.  I can't believe the LCD panel just decided to die.  Help please!!!
: Re: TS-X4.0TL/R5 LCD display not working
: 1000001101000 August 15, 2019, 03:19:41 PM
The LCD screen is controlled by a microcontroller which is somewhat separate from the rest of the system. It is possible (if unlikely) for that microcontroller to experience an issue. Sometimes this type of issue can be resolved by physically unplugging the Terastation and waiting several seconds before plugging it back in and trying again (shutdown/restart of the device doesn't cut power to the microcontroller).

: Re: TS-X4.0TL/R5 LCD display not working
: bleedish August 15, 2019, 04:30:35 PM
Yeah, I've tried that several times.  No dice.  Thanks for the suggestion though.
: Re: TS-X4.0TL/R5 LCD display not working
: 1000001101000 August 15, 2019, 04:59:52 PM
I suppose you could check to see if the cable to the lcd module came loose or something.

If the microcontroller wasn't working the device would probably not work, at the very least the leds/fans/lcd backlight/buttons would not work properly. If all of those work as expected you can be fairly sure it's just an lcd problem.

I've created a library for interfacing with the microcontroller on these devices, though it needs to be running linux (not the stock firmware) to work.

I've been working on getting this model running linux but haven't had much success so far, I can get it to boot and recognize most of the hardware but haven't got sata working (kind of important on a nas). I have been able to confirm that the microcontroller library works on this model.

If I ever get the whole thing working that would give you some more tools to troubleshoot with but ultimately if the LCD isn't displaying messages and removing power from the microcontroller doesn't work it pretty much has to be an iccue with the lcd or it's connection to the board.