Buffalo Forums

Products => Storage => : Paul.Ferrari August 12, 2019, 10:28:59 AM

: Copying data from one NAS to another
: Paul.Ferrari August 12, 2019, 10:28:59 AM
I am a relative newbie, so apologies if I'm asking a dumb question - and I have searched using GOOGLE and though the Forum too but I can't find a similar question.

I have an existing LS-CHL-V2 LinkStation (which I have SSH access to) which has around 850 GB of files stored on it.  I have recently purchased a LS 220 D (no SSH access yet) and I wish to move the files from my Original LinkStation across onto my new LinkStation.

So obviously if I do this from my PC it routes all the files through my PC - not very efficient - so I thought is it possible to mount the share from one of the LinkStations onto the other and just use the UNIX cp command ?

I have looked up mounting SAMBA Shares and tried using the mount command but to no avail :

> mount -t smbfs -o username=admin,password=**** // /mnt/test

I get an error that says "mounting // on /mnt/test failed: No such device" - I have created the /mnt/test folder and I am logged in as root.

I know the server I am logged in as can see the other LinkStation, as I can use the command

> smbclient -L -U admin

and the Shares are all shown, including the "MySharedFolder".

So I have two questions really :

1. Is it actaully possible to do what I'm trying to do ?  Can you mount the share from one NAS onto another ?
2. How do I get SSH Access to my new LS 220 D ?  I have tried ACP Commander (Ver. and it says that it's successful, but I just can't connect using PUTTY.

Thanks in advance for any help.


: Re: Copying data from one NAS to another
: 1000001101000 August 12, 2019, 11:39:49 AM
since you seem to be reasonably comfortable on a Linux command line you have some interesting options available to you.

Personally, I would just install Debian on the ls220 which would give you ssh and a working samba client. Checkout the page below for the installer images and instructions if you're interested:

I don't recall if I've ever tried getting SSH working on the LS200 series stock firmware or not but the link below is for a script that I've used successfully on the LS400 and some other models:

You might have more luck connecting ls220 ->  LS-CHLv2 rather than the other way. At some point SMBFS became CIFS which could also be part of the problem. It could also be that the buffalo firmware is missing something required for mounting samba shares to work. You could also try the rsync protocol if that was supported by the  LS-CHLv2, even if it isn't that's probably be easier to get working than samba in that case.

If you don't need both drives in the ls220 right away you could also pull the drive out of the LS-CHLv2 and mount the data partition and copy it that way.

: Re: Copying data from one NAS to another
: Paul.Ferrari August 12, 2019, 11:54:29 AM
Thnaks for the rapid reply - there's some interesting options there that I will investigate futher.

Appreciate your time and effort in replying.

: Re: Copying data from one NAS to another
: Paul.Ferrari August 27, 2019, 06:11:47 AM
So, apologies for bouncing this back to the top, but I found a solution and wanted to put it here in-case anybody else was trying to do the same thing one day and this may help them.

So, first I got SSH working using the steps outlined in the post here : https://github.com/rogers0/OpenLinkstation/tree/master/0_get-ssh
Thanks to 1000001101000 for that.

So I created a Shared Folder (MySharedFolder) on the LS 220 D using NAS Navigator.
There is a Shared Folder with the same name on my LS-CHL-V2 LinkStation (
Then once I could connect to my LS 220 D using SSH, I used the following commands as root :

cd MySharedFolder
smbclient //

This connects the new NAS to the old NAS ..... then, in the smbclient interface, check the paths are OK before doing anything

OK - so we're good to go, use the following commands :
prompt OFF
recurse ON
mget *

And that will copy over ALL files and Folders from one share on the old NAS into a folder on the new NAS.