Buffalo Forums

Products => Other Products, including computer memory => : jeff0707 June 13, 2019, 03:00:26 PM

: LS-V4 Needs Firmware update
: jeff0707 June 13, 2019, 03:00:26 PM
I replaced a drive in an old LS and I need to update the firmware (getting E06 error)  All the links I have found for this seem to have been broken.   How do I accomplish an update now.

: Re: LS-V4 Needs Firmware update
: 1000001101000 June 13, 2019, 03:28:59 PM
Check out:
: Re: LS-V4 Needs Firmware update
: jeff0707 June 16, 2019, 10:49:30 PM
Ok,  I reformatted the drive with one partition (mbr) and dowloaded the file ls_series-v174.  I extracted the updater files as well as the ulmage and initrd files and the had the buffalo extension on them.  These I copied to the blank drive to the root directory.  Plugged the drive back into the NAS housing, connected the network cable and power.  I got a flashing blue light which after a bit turned into an E06.  I also tried holding the function button while rebooting it, release it and held it again. Then it went flashing blue, one red flash then flashing blue for hours.  I tried running both the LSUpdater and the NAS NAVi program and they never see a drive that needs updating.

I never saw how to put the unit in debug mode unless I have to type that line in manually

What am I missing?

: Re: LS-V4 Needs Firmware update
: 1000001101000 June 17, 2019, 09:42:08 AM
The goal is to get the device to boot from those firmware files (initrd.buffalo and uImage.buffalo) and into EM mode, then use lsupdater (with debug options enabled) to force it to do a fresh firmware install.

to accomplish this the files have to be in the exact place that the bootloader expects them which is:
- on the first detected drive
- on the first partition which must be:
-- fairly small, I usually use 1 GB
-- formatted ext3
-- with both *.buffalo files in the root directory (which need to be extracted from uImage.img and initrd.img)

I'm guessing one of those criteria wasn't met. Give it another try and if you still have trouble post some more detail about the commands you are using and we should be able to figure out what's going on.
: Re: LS-V4 Needs Firmware update
: jeff0707 June 17, 2019, 12:57:45 PM
This is minor I'm sure but just covering bases.  The drive is a single drive unit (LS-V2 or V4)  with only a single partition and the drive is either a 1 or 2 TB.

I have it formatted as NTFS like my other NAS which works fine. 

Does it need to be ext3?

If there is just a single partition on it, does just coping the two files (initrd.buffalo and ullage.buffalo) do the trick?

Should I push the function button while booting or just plug it in?

Thanks for your help, I appreciate it.
: Re: LS-V4 Needs Firmware update
: 1000001101000 June 17, 2019, 01:23:30 PM
The only reason to hold the function button is if you are attempting to boot via TFTP. If so you are working off of different instructions than what I gave you. That process should work with the same *.buffalo files but the process is completely different. If you do go with TFTP what you do with the drive doesn't matter because you're booting from the network rather than the hard drive.

If you are attempting to boot from the hard drive (the procedure I posted earlier) then all the requirements I posted earlier apply.
: Re: LS-V4 Needs Firmware update
: 1000001101000 August 14, 2019, 10:03:40 AM
That sounds like information for a router or some other device than what the thread is about. Could you post a link to the utility you are talking about?