Author Topic: LS-WXL & E06 error  (Read 2756 times)


  • Calf
  • *
  • Posts: 4
LS-WXL & E06 error
« on: August 15, 2011, 12:41:00 pm »

Hi All,


I have LS-WXL NAS and I'm facing E06 error.

I do not know how to get rid of it. It apeared after power failure.


I tried to boot it up in EM and uploaded new firmware but everytime after reboot E06 appeared.

I removed all partitions from WD Green Caviars (1TB), checked the hard drives using WD software (S.M.A.R.T & bad sectors) and there were no faults found.

I updated LSUpdater.ini to state:

VersionCheck = 0
NoFormatting = 0

Debug = 1

ticked on all boxes in debug mode and tried upload the firmware again. HDDs were formated successfully NAS rebooted and displayed E06 again.

NAS is fairly new, but I cannot find the recipt so cannot prove that waranty is still valid.


Any ideas how to solve the problem?




  • El Toro
  • ****
  • Posts: 420
Re: LS-WXL & E06 error
« Reply #1 on: August 15, 2011, 05:28:37 pm »

Most of the time power failures causes E06.  UPS are really necessary.

You are in the right direction, but you have to follow instructions carefully.

You have to TFTP boot two times.  The first time, the drives are formatted and the second time the firmware is copied.


Check this



  • Calf
  • *
  • Posts: 4
Re: LS-WXL & E06 error
« Reply #2 on: August 24, 2011, 02:19:31 pm »

Thank you for the solution. It works!


  • Calf
  • *
  • Posts: 2
Re: LS-WXL & E06 error
« Reply #3 on: September 09, 2011, 03:03:32 pm »

Thanks for the link, selecting ONLY recreate the partition table in the firmware utility finally did it. My E06 is caused , and full reproducable, by trying to switch to RAID-1 on an LS-WXL.


  • Calf
  • *
  • Posts: 12
Re: LS-WXL & E06 error
« Reply #4 on: September 22, 2011, 09:56:26 pm »

HI,  I have the same issue.... so what the heck good is a NAS when you can't do RAID-1?  Mine has done this 2x,  not reliable in my opinion.


  • Calf
  • *
  • Posts: 1
Re: LS-WXL & E06 error
« Reply #5 on: March 15, 2019, 12:50:21 pm »
Hello All,

I am having issues getting my LS WX2.0TL/RT / LS WXL to boot into EM mode and show up on my computer in LSUpdater and NAS Navigator.

Can someone please direct me to a fully comprehensive guide on every possible step that needs taking for it to work. Thanks.

The link above is dead, unfortunately.



  • Debian Wizard
  • Buffalo
  • ***
  • Posts: 215
  • There's no problem so bad you cannot make it worse
Re: LS-WXL & E06 error
« Reply #6 on: March 15, 2019, 01:11:18 pm »

I don't know about "fully comprehensive" but most folks are successful using the following:

This all assumes you're not looking to recover data from the device, just get it functioning. If you should probably look into that before proceeding.

1. Extract the required boot files from the firmware installer for your device:

2. Get the device to boot from those files using one of these methods:

3. Enable debug mode in LSupdater:

4. Finally run lsupdater to re-install the firmware on the device
(if starting from blank drives use the re-partition and re-format settings).