Author Topic: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)  (Read 7394 times)

rpchris

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #15 on: August 01, 2011, 06:03:14 pm »

I can confirm that the above fix requiring the installation of opentera and samba 3 worked for me.  It was fairly simple to install.  

 

All the shares on my Terastation are now accessible on Mac OS X Lion.  I don't use this as a backup drive so I can't comment on that, but I again have access to my iTunes library and all of my photos and documents. *whew*


bdumd

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #16 on: August 02, 2011, 10:14:07 am »

I didn't feel that the complicated instructions were for me BUT I can access the drive (Tera HD-HTGL/R5) via Parallels (new version)


emnem

  • Calf
  • *
  • Posts: 4
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #17 on: August 03, 2011, 01:21:55 pm »

After performing the steps that krishkal listed, I was able to get the Mac to use the Nas.  The process isn't hard, but it's also not super intuitive.  It will take a leap of faith to jump into, but will be worth it when you can access your data again.

 

Thanks for your help!!


georgeajr

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #18 on: August 29, 2011, 08:40:10 pm »

Jay-

 

Since your post was a month old, I called Support for an update (as no new Firmware was posted) and they stated Buffalo is not going to come out with a Firmware update for the HD-H1.0TGL/R5.

 

Would you please update you comment and explain why those of us now looking for a new NAS should concider staying with Buffalo?

 

Thanks,

George


ampersandee

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #19 on: August 30, 2011, 11:42:45 am »

This is disheartening, I just called Buffalo support and they stated that they are working on a firmware update for HD-H1.0TGL/R5 and to check the forms for the release, but the form post are stating contrary reports from support.

 

It's looking like this NAS was abandoned long ago as the last firmware update was almost 4 years ago!

 


cnewlander

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #20 on: October 16, 2011, 01:19:57 pm »

From what link on this page  http://homepage.ntlworld.com/itimpi/telnet.htm?? is the Open Tera firmware downlaoded from?  


jarrodb

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #21 on: October 27, 2011, 11:00:05 am »

I followed the directions in the link by Krishkal, and I then could not access the NAS... via web UI or SMB.. I could still ping.  Fortunately I was able to re-do the firmware from http://homepage.ntlworld.com/itimpi/telnet.htm?, but would still like to add Samba3 if possible.. has anyone else had challenges getting OpenTera/Samba3 on the Terastation HD-H1.0TGL/R5?

 

Thanks

 

jb


GreatEscapee

  • Calf
  • *
  • Posts: 1
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #22 on: October 29, 2011, 10:28:06 am »

I did have some problems getting this approach to work on a TS-1.0TGL/R5, which sound similar to those jarrodb has experienced.

 

Read the following which have links to the downloads hightlighted below.

http://homepage.ntlworld.com/itimpi/telnet.htm#TERA_ORIG?

http://homepage.ntlworld.com/itimpi/opentera.htm??

 

1. Applied telnet enabled firmware 1.12 using English updater - OK

2. Applied OpenTera firmware - OK

3. Used MakeSpace script - broke web UI

4. Re-applied 1.12 - OK web interface back

5. Re-applied OpenTera firmware - OK

6. Applied Samba 3.0.25 with AD support - Not OK, could not access from PC

7. Applied Samba 3.0.37 - OK, had to use muCommander to copy it over

 

By following the directions offered by Krishkal it was ultimately successful. However, even after installing Samba 3.0.37 I had problems with access (I am guessing permissions - really don't know anything technical) which even broke access via muCommander on certain folders. The access problems seemed to go away with deleting folders, re-booting the TeraStation and re-creating them.

 

I don't use Time Machine either but I have fired it up and started a back up as a test, which didn't work as it looked for the backup disk then reported the backup disk was not available.

 

I felt a little out of my comfort zone doing this, so it is quite possible I caused some of these problems and not the firmware updates. I wouldn't have known where to start if I didn't have a PC to copying the files over with, and more importantly back up the data on the TeraStation. Having said that I couldn't use the TeraStation as I wanted under Lion so had nothing to lose. Obviously, back up first and at your own risk update.

 

The low risk approach to gaining file access is muCommander which I discovered from here.

https://discussions.apple.com/thread/3189768?start=0&tstart=0?

 

I used:

1. Telnet enabled firmware

http://downloads.nas-central.org/Users/itimpi/terapro_112e.zip?

 

2. OpenTera firmware

http://downloads.nas-central.org/Users/itimpi/OpenTera_v5.zip?

 

3. Samba 3.0.37

http://downloads.nas-central.org/Users/itimpi/samba-3.0.37_ppc.zip?

 

 


pdasilva

  • Calf
  • *
  • Posts: 2
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #23 on: November 17, 2011, 09:42:12 pm »

My experience is that Lion has upgraded the smb protocol stack and is using a more secure authentication procedure.  I asked Apple's fine engineers for instructions on how to deprecate Lion's smb security protocol back down to Snow Leopard's level.  They suggested using the following command that needs to be run in a terminal window everytime Lion boots:

 

 

 

sudo sysctl -w net.smb.fs.kern_deprecatePreXPServers=0

To restore the smb protocol stack back to Lion's original state either reboot or run in a terminal window:

 

 

sudo sysctl -w net.smb.fs.kern_deprecatePreXPServers=1

zaklee

  • Calf
  • *
  • Posts: 9
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #24 on: March 11, 2012, 07:59:05 pm »
Rpchris, are you connection using AFP or SMB after installing OpenTera? Guessing SMB b/c of instruction to install Samba. What is the functional difference between the two?

crickw

  • Calf
  • *
  • Posts: 3

Thanks.  This solutions works for my Lion 10.7.3 and HD-H1.0TGL/R5

Wrote an AppleScript to automate that makes it easy to re-connect the drive after those all so infrequent OS restarts.

 

[Automator>Untilities>Run AppleScript]  Paste the following into the input dialog and save as something like Legacy_SMB_Connect.app in your Applications directory.

 

tell application "Terminal" to activate
do shell script "sudo sysctl -w net.smb.fs.kern_deprecatePreXPServers=0" with administrator privileges
tell application "Terminal" to quit
end



noname

  • Calf
  • *
  • Posts: 4
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #26 on: September 09, 2019, 01:18:16 pm »
I know this is VERY OLD thread, and I apologise for necroposting, but if someone could share OpenTera_v5.zip and Samba .zip. It seems that nas-central.org is down. Thank you all in advance!

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 384
  • There's no problem so bad you cannot make it worse
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #27 on: September 09, 2019, 01:40:15 pm »
Looks like the creator's page is still online:
https://itimpi.updog.co/opentera.htm

I suppose you could contact them and see if they still have a copy.

I believe back in the day I had some luck porting Debian Sarge (3.1) packages to my HD-HTGL but didn't do much with it, certainly nothing as complicated as trying to replace samba.

noname

  • Calf
  • *
  • Posts: 4
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #28 on: September 09, 2019, 02:11:59 pm »
Thank you very much for quick reply!

When I go to this page and try to download anything, nothing happens...

I guess I'll need to contact them for copy of OpenTera.


P.S. I just did... And I got this:

DNS Error: 10660730 DNS type 'mx' lookup of itimpi.freeserve.co.uk responded with code NXDOMAIN Domain name not found: itimpi.freeserve.co.uk

« Last Edit: September 09, 2019, 02:19:24 pm by noname »

1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 384
  • There's no problem so bad you cannot make it worse
Re: TeraStation HD-H1.0TGL/R5 unable to be accessed by MAC OS X Lion (10.7)
« Reply #29 on: September 09, 2019, 02:38:03 pm »
I tried messing around with some of this type of stuff on the HTGL back in ~2012 and found that most project were no longer active. Likewise around that time most distros dropped PPC support which also limited the tools that were available. I got rid of mine around that time.

Considering these devices are getting to be ~15 years old at this point I doubt you'll find much help with it. Depending on what your issue is that customized firmware from ~7+ years ago probably wouldn't solve your current issues anyway (unless you are trying to connect in OSX 7 like the OP).