Author Topic: TeraStation Pro - cannot connect - and solution  (Read 6214 times)

MarkDerail

  • Calf
  • *
  • Posts: 2
TeraStation Pro - cannot connect - and solution
« on: December 30, 2008, 10:49:58 am »
   

I never found a complete post to fix the problem I had with my TeraStation Pro (TS-2.0TGL/R5), where I lost connection when a drive failed, and even replacing the drive and rebooting, clearing the error beep (by pushing the Power button). I purchased through Dell Canada w/Dell's business warranty (another future post).

 

So far, this was the third 500g drive to fail on me since I bought this unit in Sept 2006. The first time around, , in Oct 2008, I did the shutdown procedure, changed for a 1TB Sata, rebooted, pushed the power button once to stop the beep. The console said the Link was active, and Http://{ip address} worked fine.

- home page

- clicked the error message link

- selected the new drive

- clicked on rebuild

 

Didn't even bother formatting ahead of time. Doing refresh on the Disk Management page, showed Rearing (0.0%) then sometime later, Syncing (1.0%) and so on, util 100% then All-OK.

 

Second 500g Sata failed two weeks later! So I got a second 1TB Sata of same make/model (Seagate this time. Originals were Western Digitals Caviars wd500ks). Repeated steps I mentioned above. Perfect.

Two out of two. Flawless. (Yes I was impressed

 

Of course, since my setup was as a 1.6TB Raid-5, I did not want to wait for the other two 500g to fail on me, and lose all my data. I when the second 500g failed, I got three more Seagates 1TB of same make/model.

 

Not a week after the second 500g drive fail, a third original HD fails! Then the nightmare starts. I can PING, but that's it. Can't connect to it. The Google searches looked GRIM. The Serial Port is in UPS mode, so I can't login into the Linux to try something. Time to hit the forums/faq.

 

The Buffalo NAS Navigator was able to talk to it via Mac address. Go to the download page, choose the product, download the files...

http://www.buffalo-technology.com/support/downloads/

- Utility

- Firmware

 

The NAS Navigator said the TeraStation Pro was in EM mode, and I had to call TechSupport (OMG!) or flash the firmware, to clear out the error. Cool, now I'm getting somewhere. I had never flashed the system from the original purchase (if it isn't broken don't fix it).

 

So I unzipped the flash utility in the c:\program files where NAS Navigator is located, in a new folder. (BUFFALO - a setup.exe or .msi would have been a nice touch here) Then I ran it, it found via Mac address the unit, and proceeded to do it's thing. Some ten minutes later, I was FUNCTIONAL again. Hurray!

 

Once I'm synced again, I will break the Raid-5 by unplugging the last remaining 500g drive, and replace it with my last 1TB drive, and sync it up, and will be left when three "dead" 500g WD HD's and one "about to die".

 

Now the real fun will begin, getting DELL to service the unit under it's "extended warranty".

I'll unplug my four 1TB's, labelling them 1 through 4 to re-install them later in proper order.

Then get DELL to service the unit - which I'll post my experience back here.

If I'm lucky DELL will simply give my three or four new 500g HD's, that I'll use elsewhere.

(most likely I'll have to ship to DELL and hopefully get a cross-ship going). 

 

So, be prepared with replacement HD's if you *really* need your data on the NAS box. Other people will most likely have cascading HD failures like I got. If you don't rebuild you array fast enough, your data will be lost.

 

I also read elsewhere, a UPS is a must - I recommend a 750va minimum for a 4-disk TeraStation.


Paul

  • Big Bull
  • *****
  • Posts: 1223
Re: TeraStation Pro - cannot connect - and solution
« Reply #1 on: December 31, 2008, 11:09:17 am »

Have you ever tried to restructure the array with the "defective" drive?

You will get the same error if the raid controller miss writes data to that drive.

This could be a controller issue.


MarkDerail

  • Calf
  • *
  • Posts: 2
Re: TeraStation Pro - cannot connect - and solution
« Reply #2 on: January 08, 2009, 12:56:04 pm »
   

I thought it could be a controller issue also, however, TeraStation kept reporting that the HD had a fail, even after a cold boot. TeraStation refused to recognize the drive.

 

Then when I did the first swap, it was ok, so why bother dissing with a potentially bad HD. After all, this was 25 months later with a 24/7 uptime.

 

I will try one of those 'defective' HD's in a regular computer to see if the Bios sees it, and if it does, I'll try formatting it NTFS and copy some ISO's on it, just to see.

 

If it is a controller issue, hopefully the latest flash will have fixed that.

 


Zod

  • Calf
  • *
  • Posts: 4
Re: TeraStation Pro - cannot connect - and solution
« Reply #3 on: January 17, 2009, 05:12:56 am »
   

Hi Mark

 

I have the exact same model as you do (TS-2.0TGL/R5 ).. can the unit take 1TB drives and RAID them ?

 

thanks