Author Topic: Cannot access SOME shares ts-h4.0tgl r5  (Read 2153 times)

J3tstream

  • Calf
  • *
  • Posts: 7
Cannot access SOME shares ts-h4.0tgl r5
« on: January 26, 2011, 08:56:12 am »

Model TS-HTGL/R5 F/W 1.35

Firmware 1.35

 

The NAS is in a WORKGROUP

I have 2 PCs to test it from -both behave the same one is XP one is Win2K3 Server (I have a VM as well - same behaviour)

PCs & NAS are plugged into the same Dell 2808 Powerconnect GB Switch

NAS Navigator detects the NAS no problem

Web Control panel works fine

I can run \\Hostname to the root folder ... also used IP address

I can access 2 shares in this folder and copy data from them

2 other Shares I cannot access

There is plenty of space on it ... only 300GB used out of 2.7TB

 

The Error

 

\\192.168.0.11\share is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The network name cannot be found"

 

If I browse using exlporer the share can be seen - just not accessed (same error)

 

Straws I have been clutching at - which haven't helped

  • I have removed the Access restrictions / re- enabled that
  • Changed the Apple/Backup/FTP settings
  • Removed the descriptions
  • removed users - re-added them
  • Updated the firmware to 1.35_1.39
  • Firmware update went OK
  • It was originally DHCP - I have changed it to manual
  • Created a new share - this works OK
  • Renamed a share that doesn't work
  • Renamed the NAS
  • Rebooted ... a few times
  • reset to factory defaults
  • Changed the time/timezone

I think I have exhausted things to try - the ability to access some shares an not others when they are configured the same just doesn't seem to make any sense.

I hope someone can put me out of misey :mansad:

 

Cheers

J

 


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #1 on: January 27, 2011, 10:59:57 am »

try accessing the files from an ftp client. If that doesn't work, try creating a backup in the terastation from the shares you want to a new share and see if you can get to the data. The folders may be corrupt. 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #2 on: January 28, 2011, 08:58:48 am »

Thanks for the reply Jotin

I have tried FTPing to the box ..I can log in but the root folder is array1 ... with no files or options to go to other folders ...

Corrupt folders? This is worrying ... I have a few of these in Hopitals with medical data on them ... They "should" be backed up by the local IT ...

Strangely something similar happened to a colleague last year ... but he was lucky .. he said all he did was change the system time (go figure! - which is why I did it above ) and it burst into life ...same symptoms-refusing authentication

 

The backup route  - are you suggesting plugging a usb drive or literally just to another share on the same box ? then copying the data by kicking off a "backup" from the web control panel?

 

I will give it a go ... thanks for the suggestion

 

Feeling a little sick right now at the thought of having to **bleep** these boxes..

Cheers

J


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #3 on: January 28, 2011, 09:03:02 am »

You could either do a back up to a USB drive or you can just create another share folder on the TS and do a backup to that folder to see if the data becomes available. And when ftping into the device you have to make sure that the ftp service is enabled in the network services and that the folder that you want to access has ftp enabled on it under the support options for that folder. 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #4 on: January 28, 2011, 09:25:26 am »

OK FTP

I can FTP to the box and see the new/other shares ... the shares that are available from windows are the same folders available in FTP. My missing shares are not available in FTP.

 

Backup

I have created a backup job - set to run immediately

I can select the share I want to back up but the only detsination I have is HOSTNAME@Archive

If I apply this and go back to the top level of backup it says "an error has occured" :-O   ... no really?

 

I have also managed to get a USB drive plugged in (HOSTNAME@usbdisk1 ... same result  "an error has occured"

 

Cheers

J


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #5 on: January 28, 2011, 10:25:42 am »

Ok, so when you say you reset the unit to factory defaults, what did you do exactly? 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #6 on: January 28, 2011, 10:28:33 am »

There in a button in the Web Control panel > Maintenance> Initialization> Restore Defaults

 

It didn't seem to do a huge amount to be honest ...


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #7 on: January 28, 2011, 11:11:39 am »

That should have completely reset all of the settings in the interface. Try doing this. Go to FAQ 2 of 5 pinned at the top of the storage forum and follow those instructions. During the walk through you'll get to the debug options. Along with the settings it mentions, also choose delete user config and follow through with the force update. 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #8 on: January 28, 2011, 11:51:45 am »

I ran the firmware updater .. ( I had ran it previously and updated the firmware successfully)

I selected the delete user config as suggested in the guide. It all went smoothly ...

 

Unfortunately the symptoms are exactly like before.. 2 shares unavailable

 

The 'created' user was still there even after firmware update with delete user config selected... I guess this might be normal ... config deleted - user remains

 

I realy appreciate the help BTW


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #9 on: January 28, 2011, 01:23:31 pm »

That's really strange. The delete user config should have deleted the user that you created. How long have you had your unit for? 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #10 on: January 28, 2011, 02:25:59 pm »

The unit was at a customer from Aug 2008 (when it was new) until Aug 2010 ...

 

 

 


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #11 on: January 28, 2011, 02:41:06 pm »

It seems like your unit is not resetting properly. Is the data a backup or is it the only source of the data? If its the only source technical support can create an advanced replacement for you, get a unit out to you and you can swap the drives into the new chaise and see if you can access those shares. 


J3tstream

  • Calf
  • *
  • Posts: 7
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #12 on: January 28, 2011, 07:38:49 pm »

If I understand you correctly you are suggesting getting the HDDs moved into another chassis ...?

I have access to a desktop terastation ... which I believe is basically the same just different form factor .. maybe try the disks in that?

I would be surprised if it worked ... but currently I will try anything ...

 

At the moment it has gone beyond the importance of the data that is currently on there (I am fairly sure I have other copies).. it is knowing why it happened & how do I fix it ...

 

 

Cheers

J


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: Cannot access SOME shares ts-h4.0tgl r5
« Reply #13 on: January 31, 2011, 08:35:36 am »

It sounds like your unit is not completely restoring. It sounds like the permissions somehow became corrupt and the file will not be reset. If you move your drives to another unit and flash the firmware you might have access to the data again. But since you have copies of your data I would just format the terastation.