Author Topic: Shared Music now broken with itunes 10 on osx >_<  (Read 4460 times)

VirtuaMcPolygon

  • Calf
  • *
  • Posts: 13
Shared Music now broken with itunes 10 on osx >_<
« on: September 02, 2010, 05:28:19 pm »

Having just installed itunes 10. I've noticed all my shared music from my linkstation duo is now inaccessible. It shows up in itunes on the side bar as a shared device but will not display any music!

 

I've tried it on my ps3 and xbox and it's still working ok and have restarted both my router and linkstation.

 

Any ideas???


Ollebro

  • Calf
  • *
  • Posts: 3
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #1 on: September 03, 2010, 05:55:19 am »

AH! So thats why all my music disappeared! thought i did something to the NAS.


Ollebro

  • Calf
  • *
  • Posts: 3
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #2 on: September 03, 2010, 05:59:46 am »

This problem exist on windows and iTunes 10 to.

i have the latest firmware 1.34 on my LinkStation Live LS-CHLv2


ghsbloke

  • Calf
  • *
  • Posts: 2
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #3 on: September 03, 2010, 12:01:48 pm »

I'm using iTunes 10 with Windows 7 using an LS-CH Linkstation / firmware v1.34, same problem has occured, glad I'm not the only one but has this yet come to the attention of the techies at Buffalo?


jzaidman

  • Calf
  • *
  • Posts: 1
Re: Shared Music now broken with iTunes 10 on osx >_<
« Reply #4 on: September 03, 2010, 04:03:26 pm »

Same issue here. I am using LS-XH2.0TL and tried it with both firmware 1.33 and 1.34. I can see the NAS under SHARED in iTunes 10 on Windows, but there are no media files listed.

 

I just called Buffalo tech support, but the guy I was talking to had no clue if and how iTunes support in their product should work. He basically said that if I can't see the files, his guess is that's how it is supposed to be! He seemed to be quite annoyed with me trying to get him to troubleshoot it and eventually agreed to send an email to their software team, with no commitment to do any kind of testing or resolution.

 

I can appreciate that this issue seems to have been triggered by Apple upgrading iTunes to version 10, but I would have expected Buffalo to be on Apple beta programs (as all the other ISV's) and should have figured out that there is an issue before 10 was released, and either fixed it or at least posted a bulletin on their support site.

 

Jakov

 


ghsbloke

  • Calf
  • *
  • Posts: 2
Re: Shared Music now broken with iTunes 10 on osx >_<
« Reply #5 on: September 06, 2010, 05:47:20 am »

I've only recently purchased my Linkstation and the iTunes server is a feature of the product with no mention of it not supporting future releases of iTunes, unless some form of statement is made by Buffalo soon I think we have grounds to return our products for a full refund.


gmbinom

  • Calf
  • *
  • Posts: 2
Re: Shared Music now broken with iTunes 10 on osx >_<
« Reply #6 on: September 06, 2010, 10:19:48 am »

i hope they are on this case. Because if they are not i will bring my Linkstation back to my dealer ....


roblicsw

  • Calf
  • *
  • Posts: 17
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #7 on: September 08, 2010, 10:19:35 am »

Definitely a major problem..check out the iTunes forum in Apple.com support...it's clogged with complaints from owners of every brand of NAS


Ollebro

  • Calf
  • *
  • Posts: 3
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #8 on: September 08, 2010, 12:35:47 pm »

apple removed DAAP support from iTunes 10 = no more music from NAS devices...


benfrain

  • Calf
  • *
  • Posts: 3
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #9 on: September 08, 2010, 03:28:38 pm »

What a pain in the arse. If anyone is stuck getting things working again with Linkstation and rolling back to iTunes 9.2 I've written a brief tutorial: http://benfrain.com/notepad/2010/09/itunes-10-doesnt-work-on-nas-drives-how-to-downgrade-to-itunes-9-2.html (it's OSX specific mind)


Sunnyfield

  • Calf
  • *
  • Posts: 5
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #10 on: September 13, 2010, 09:19:11 am »

I wish I had read this one week earlier! Same here: iTunes 10.0.0.68 on XP and Vista. No songs visible from my Quad (LS-QL/1D with firmware 1.11 on RAID5). What a rotten apple!


drmemory

  • Big Bull
  • *****
  • Posts: 1147
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #11 on: September 13, 2010, 04:30:07 pm »

We are working with Apple on this. That's all I can say about this at the moment, but I will update as I get more information.


gmbinom

  • Calf
  • *
  • Posts: 2
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #12 on: September 14, 2010, 04:52:04 am »

I think it will be the next step to get Airplay ready to NAS.... I read something like the data has to be spcified as Music or Video etc. The big picture will be that iphone, ipod, apple TV and iTunes will play the streamed data and can send the data to other devices.


peshko

  • Calf
  • *
  • Posts: 2
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #13 on: September 17, 2010, 08:58:53 am »

As I pointed in another post, I think that the problem is much bigger than just looking at how itunes translates daap. I disabled the media server on my Buffalo Terastation and tried to use the NAS as a simple smb mounted fs. Started iTunes 10 and pointed to the library on the NAS. It was a disaster. Opening iTunes 10 took me a pathetic 35 min. To sync my iPhone4 took hours, with no new content to be synced. 

To update my iPhone iOS4 to 4.1 so far takes probably about 45 min just to extract the file (download took 2 min).
For comparison on my wife's iTunes 9.2.1, with remote Library on the same NAS, to open iTunes takes about a few seconds. And she updated her iPhone to 4.1 in less than 5 minutes.
I am not using anything that is suppose to be 3rd party software ie Twonky, etc. I am simply mapping the same remote library that I used to map in 9.2.1....only now it is ridiculously slow. 

 

As I pointed in another post, I think that the problem is much bigger than just looking at how itunes translates daap. I disabled the media server on my Buffalo Terastation and tried to use the NAS as a simple smb mounted fs. Started iTunes 10 and pointed to the library on the NAS. It was a disaster. Opening iTunes 10 took me a pathetic 35 min. To sync my iPhone4 took hours, with no new content to be synced. 


To update my iPhone iOS4 to 4.1 so far takes probably about 45 min just to extract the file (download took 2 min).


For comparison on my wife's iTunes 9.2.1, with remote Library on the same NAS, to open iTunes takes about a few seconds. And she updated her iPhone to 4.1 in less than 5 minutes.
I am not using anything that is suppose to be 3rd party software ie Twonky, etc. I am simply mapping the same remote library that I used to map in 9.2.1....only now it is ridiculously slow. 


tommy4101

  • Calf
  • *
  • Posts: 1
Re: Shared Music now broken with itunes 10 on osx >_<
« Reply #14 on: September 18, 2010, 02:07:16 am »

Is it possible for you to contact me (and the others here) when a fix is made? Will they change itunes or do we have to update something on the Linkstation?