Author Topic: LS-WSXL no admin access after firmware update  (Read 1931 times)

colinwray32

  • Calf
  • *
  • Posts: 16
LS-WSXL no admin access after firmware update
« on: August 13, 2010, 04:41:48 pm »

PC, WinXP Pro, single LS-WSXL Linkstation Mini 500GB RAID 1, firmware upgrade from 1.22 to 1.33. Had unit for 4 days.

 

Bad news: Web Access login as 'admin' loops on "the current session has expired, please sign in again".

I do not get to see the first screen, just the frame and a pause, then the message box.

Same whichever username I try.

 

Good news: NASNavigator sees the unit, reports firmware 1.33, correct IP etc.

Windows maps the share folder ok, and all my data is accessible.

It has remembered my admin password (getting it wrong produces an immediate error).

 

Tried switching off, waiting 10 mins, switching on again.


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #1 on: August 13, 2010, 06:34:21 pm »

I'm constructing an FAQ on this particular subject which will be up soon.  In the meantime I would suggest looking over the manual again on setting up restrictions for Web Access.  Thank you for your patience.


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #2 on: August 14, 2010, 04:17:21 am »

After ploughing through lots of seemingly unrelated postings I came across a reference to a bug involving Firefox.

I tried using IE and, lo and behold, it works ok.

 

According to the post, v1.33 contains a fix for this: I am sorry to report that this is false.

The bug was not present in v1.22 (fortunately, if it had been the unit would have been back in its box).

No different this morning after a night's rest.

 

Firefox 3.6.8 (latest version), WinXP Pro with all updates, IE 8.0.6001.18702

3Com router 3CRWDR100A-72 v2.06

 


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #3 on: August 14, 2010, 02:49:40 pm »

This is most likely due to the folder that you want on Web Access not having it's Web Access folder setup correctly.  If you go to Web Access under the Extensions category and click on one of the share folder links is the Web Access setting set to Disable, Allow Anonymous or Allow All Groups / Users?


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #4 on: August 15, 2010, 04:58:10 pm »

I was not refering to Web Access, I am taking about the basic local admin access which is set to username:admin, password:password by the factory.

 

After installing V1.33 it was not possible to access the unit (say from NAS Navigator) if Firefox is the default browser because it continually reported session timed out, please login again, before displaying the settings page.

 

Other postings claim that this was fixed in 1.33, well it is not.


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #5 on: August 15, 2010, 05:09:32 pm »

 

I'm afraid you were and that's where I got confused:

colinwray32 wrote:

PC, WinXP Pro, single LS-WSXL Linkstation Mini 500GB RAID 1, firmware upgrade from 1.22 to 1.33. Had unit for 4 days.

 

Bad news: Web Access login as 'admin' loops on "the current session has expired, please sign in again".

I do not get to see the first screen, just the frame and a pause, then the message box.

Same whichever username I try.

 

Good news: NASNavigator sees the unit, reports firmware 1.33, correct IP etc.

Windows maps the share folder ok, and all my data is accessible.

It has remembered my admin password (getting it wrong produces an immediate error).

 

Tried switching off, waiting 10 mins, switching on again.


Unless you were trying to refer to the Web GUI.  Furthermore, other postings may result from other regions including ours here in the US.  Please bear this in mind when posting, it is appreciated.


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #6 on: August 15, 2010, 05:21:18 pm »

Yes ,sorry about that. NasNavigator right-click menu offers "Open Web Admin" so I was wrong to say "Access". (using the word "Web" when "Browser" would be better is the problem here).

 

However, we shouldn't let it detract from the fact that you cannot use Firefox for this.

 


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #7 on: August 15, 2010, 05:35:52 pm »

Same problem occurring with other browsers too?  IE or Chrome?


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #8 on: August 15, 2010, 05:40:03 pm »

No problem with IE, didn't try chrome.


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #9 on: August 15, 2010, 05:42:51 pm »

Hmmm, wonder if it's a script execution problem within Firefox.  Is Java up-to-date?


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #10 on: August 15, 2010, 06:00:31 pm »

That's interesting, I have been getting Java update errors from time to time. The only reference I can find to Java in Firefox is Java Console 6.0.20 in the add-ons list, and a Java Console menu item which does nothing.

 

There were add-ons listed of Java Console versions going back to 6.0.02, but I just deleted them all.

Unfortunately I cannot re-test because the Linkstation is in its box waiting to be replaced due to disk1 failure.


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #11 on: August 16, 2010, 03:08:19 pm »

Guess we just gotta wait on it then.  Let me know what happens when you get your replacement :)


colinwray32

  • Calf
  • *
  • Posts: 16
Re: LS-WSXL no admin access after firmware update
« Reply #12 on: August 17, 2010, 11:13:18 am »

New unit arrived with v1.31 software - Firefox problem present. Changed to v1.33 - no difference. (Remember that my original unit was ok when it had 1.22 software).

 

Firefox 3.6.8 with Java Platform SE6 U20 6.0.200.2

 


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: LS-WSXL no admin access after firmware update
« Reply #13 on: August 19, 2010, 12:37:52 pm »

Any type of countermeasure software such as McAfee, Norton, etc?