Author Topic: 1TB DriveStation TurboUSB Beeping  (Read 963 times)

sarvo_uk

  • Calf
  • *
  • Posts: 1
1TB DriveStation TurboUSB Beeping
« on: March 25, 2010, 04:54:59 pm »
   

Hello All,

First of all thank you for this great forum, exactly what i need at this time of distress.....I am wondering if you can assist me with the following issue please.

 

I have a 1TB DriveStation TurboUSB which has been running well for a year or so. But suddently now, when I connect the drive and power it on, It gives 4 long beep (amlost sound like a drive spinning, beep around 5 seconds long) followed by a much more longer beep (around 15 seconds) and then another 4 long beeps (like the first beeps) untill sudddently the drive stops totally.The green light in front of the drive is a steady green through out.

 

It could be a red herring, but I have realised that the USB connector on the drive seems a bit loose.

 

The data on the drive is totally encrypted using Truecrypt but I do need to get the data back as it has some data which is extremeley valuable to me. Is this something that you can assist me with please? What does a single long beep stand for?

 

The model number of the device is HD-CE1.0TU2-EU.

 

Many Thanks

Sav Singh


Caleb

  • Calf
  • *
  • Posts: 17
Re: 1TB DriveStation TurboUSB Beeping
« Reply #1 on: March 26, 2010, 04:31:56 pm »
   

I've never heard of that model even having beep codes to it. See if it can be found in disk management or in device manager and try a different usb cable / port, just to start. And also listen to make sure the drive isn't making any clicking / grinding noises. Unfortuneatly though if the device is defective only way to get that data back would be going through a data recovery service which is pricey.

 

Cheers