Author Topic: connecting a USB drive to a LinkStation  (Read 10649 times)

adg

  • Calf
  • *
  • Posts: 2
connecting a USB drive to a LinkStation
« on: November 07, 2009, 12:36:32 pm »
   

when I plug a USB external drive into the back of a LinkStation, the USB will let me read but not write. I get a message that I do not have permission to write. when I go to proporties and try to change permissions for the USB drive it gives me a message that I do not have permission to change the permissions. is there a way around this?


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: connecting a USB drive to a LinkStation
« Reply #1 on: November 07, 2009, 12:47:03 pm »

What is the format.  Fat32 is read only but if it's formatted to XFS it should work fine.


adg

  • Calf
  • *
  • Posts: 2
Re: connecting a USB drive to a LinkStation
« Reply #2 on: November 07, 2009, 12:54:34 pm »
   

it is formated as NFTS. i don't see an option for XFS. i should mention i am running this on Windows Vista. thanks.


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: connecting a USB drive to a LinkStation
« Reply #3 on: November 07, 2009, 01:03:45 pm »

You cannot use NTFS with these units, they run XFS (a linux file system).  Try formatting the drive throught the web interface of the linkstation (Go to disk management then disk format)


sethz

  • El Toro
  • ****
  • Posts: 252
Re: connecting a USB drive to a LinkStation
« Reply #4 on: November 07, 2009, 02:57:05 pm »
   

Just to give a further explanation so you know why you have to do the reformat, Buffalo NAS's are not native Windows devices. NTFS is actually a format made specifically for Windows. Thus, in order for a drive with NTFS to be networked, it would essentially have to have a form of the Windows OS on it.

 

The Buffalo utlizes a protocol called Samba to translate between the XFS and NTFS formats. This is why you can swap files over a network. But since the drives are in XFS, you cannot just plug it in through USB and have access. This also means after you format your USB drive, it won't be able to be read in a Windows USB port.


CB3Dot

  • Calf
  • *
  • Posts: 4
Re: connecting a USB drive to a LinkStation
« Reply #5 on: December 11, 2009, 03:28:31 pm »
   

This article was actually found on the Buffalo Web site in the FAQ section (I Think).  It also works if you are running Windows 7.  The first option is the easiest as there are only a few strokes.

 

If you want to connect to a share on a Buffalo Terastation (which seems to be using Samba) from a Windows Vista installation, you need to do the following:

  • Run the Local Security Policy app - secpol.msc
  • Go to Local Policies | Security Options and choose the "Network Security: LAN Manager Authentican Level" item
  • Set it to "Send LM & NLTM, use NTMLv2 session if negotiated"

And that should sort you out. [Update] For those of us unlucky enough to be running Vista Home (which doesn't come with secpol), you can do the following (thanks to Patrick in the comments for this)

  • Run regedit (Windows-R, 'regedit') to open the registry editor
  • Find key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\
  • Change the value for the option "LMCompatibilityLevel" from 3 to 1.

Now you should be able to access the TeraStation (you may need to reboot)


CB3Dot

  • Calf
  • *
  • Posts: 4
Re: connecting a USB drive to a LinkStation
« Reply #6 on: December 11, 2009, 03:41:40 pm »
   

Sorry, I misread your problem.  I thought it was a connectivity rather than a file format issue.  The only option for formatting on the linkstation is XFS.  If you go to Disk Management and select USB, at the lower part of the page you will find the button for the Format command.  If the format appears to fail, do the following:

  1. Press the LinkStation power switch for about 30 seconds until it stops blinking and all lights are out.
  2. Unplug the USB connection from the Linkstation, and power the USB drive off.
  3. Power USB drive on
  4. Plug USB connection into Linkstation
  5. Restart Linkstation
  6. Check to see if you see the USB drive in Disk Management. (You might find that it did previously format XFS, but did not refresh.  If not, try the format again.
  7. It worked for me.