Author Topic: Need help with Linkstation Pro Duo 2TB - 7 red flashes  (Read 12597 times)

algorhythmn

  • Calf
  • *
  • Posts: 4
Need help with Linkstation Pro Duo 2TB - 7 red flashes
« on: December 10, 2009, 05:22:14 pm »
   

My original issue was 1 reported failing (not dead) disk in my RAID and I attempted to rebuild it.  I proceeded to and now it's left flashing the red light 7 times at me.  I have data on these drives I'd like to retrieve, absolutely.

 

So far I have searched this forum and read through a ton of articles and have tried everything.  I am now at a dead end (spend hours!).  I wanted to know what to do next or if there are any other options for my issue with my pro duo?

 

I have done the TFTP, the EM boot successfully.  I can get the device that far but that's where I reach a dead end.  I can see it in the NasNavi and it confirms EM mode.  It also keeps attempting to update the IP address.

 

I have attempted flashing firmware using the debug mode and normal mode.  I am able to see the NAS with both 3.09 and 3.10 applications and attempt firmware updates (with most every combination of debug mode other than rebuild partition), but I keep getting 2 errors, randomly:

 

1 - Failed to formatting. (ACP_STATE_FAILURE) Updating is aborted.

This error appears immediately

 

2 - Failed to formatting (0XFFFFFFFE) Updating is aborted

This one appears to be doing something for about 10 minutes then this error pops up.

 

I have read a few posts that say this may be a motherboard failure and to "contact support".  But that's as far as I've seen.

 

Can anyone help me here??  your help is greatly appreciated!!!!!


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #1 on: December 11, 2009, 03:07:50 am »

7 flashes means that a HDD is bad, and ACP state failure can indicate motherboard failure.  I would contact support for a replacement (assuming the units still under warranty).


algorhythmn

  • Calf
  • *
  • Posts: 4
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #2 on: December 12, 2009, 12:20:25 pm »
   

thank you for the reply

 

That makes sense 1 drive is bad, that was what the device originally indicated that required a RAID rebuild.

 

Is there any way to tell which drive is bad?

 

Could try to get to EM mode and flash the firmware with NO drives attached?  or try one/other until it works?

 

I just want to get my data off the good remaining drive at this point....

 

thanks!

 

 

 

 

 


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #3 on: December 15, 2009, 05:08:35 am »

To do that you would have to disassemble the unit which is something that we don't support and it can void your warranty.


JoshC

  • Big Bull
  • *****
  • Posts: 1110
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #4 on: December 15, 2009, 05:46:04 am »

On the ACP-state -failure you can try to rebuild the partition but you will lose all of your data.


algorhythmn

  • Calf
  • *
  • Posts: 4
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #5 on: December 15, 2009, 04:31:02 pm »
   

I actually did try to rebuild including the partition within debug mode (after I gave up hope) but even that failed to work. 

 

Is it safe to say the firmware is NOT present on the drives?

 

Or does the firmware actually get stored within the boot sector on the drives or something?


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #6 on: December 15, 2009, 05:15:42 pm »

The firmware is stored on the drives. When it comes up in Emergency Mode, it has booted of the recovery partition on the flash chip.

 

7 flashes typically means an unrecoverable error, either on the motherboard, RAM, LAN card, or HDD controller.


algorhythmn

  • Calf
  • *
  • Posts: 4
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #7 on: December 16, 2009, 12:26:52 pm »
   

Okay let me ask this.......

 

Assuming it is not a hardware failure (meaning only 1 bad harddrive is my issue), does the potential exist for me to update the firmware with only the ONE good harddrive attached?

 

I could attempt the EM boot and firmware flash once for each drive to see if either works?

 

Otherwise I actually have 2 of these devices which introduces an entire new potential for me to "Swap" drives from bad to good hardware in effort to recover data.  But I'd rather exhaust all options above before I end up having two failed systems :)

 

your help is greatly appreciated thanks

 

 

 

 

 

 


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Need help with Linkstation Pro Duo 2TB - 7 red flashes
« Reply #8 on: December 17, 2009, 02:56:52 am »

No, you cannot flash the firmware onto just one drive.  Also understand that disassembling these units will void your warranty.  If this is not a concern to you, then I suggest making sure they are the same hardware version (the version one has 1 USB port and the version 3 has 2).  If they are not the same then a HDD swap isn't possible.