Author Topic: Crashed LS420D8A8  (Read 196 times)


  • Calf
  • *
  • Posts: 1
Crashed LS420D8A8
« on: September 08, 2020, 11:35:50 am »
Hi. If this is a duplicate post I apologise.
Following several power cuts my LS420D8A8 is showing a continuous error signal of 2 long red flashes and 2 short red flashes that the manual says to format the drives.
Prior to the power cuts the unit was running fine.  I cannot turn the unit off on the power switch.  I have turned the mains off with the power switch off and turned on with the same error.  I can Ping the unit but not see it with Win 10 even putting in the IP address and the navigator does not find it.

I have tried the WEB Interface but just get a grey screen with a few slightly different boxes but no interface.

Since original post I removed the drives and turned the unit on and go 7 short red flashes, software corupt.

Has anyone any suggestions?


Post Note

I contacted Buffalo Technical Support Portal (  They were very helpful, although out of warranty, and provided information to restore the unit back to working although I lose the data.  I can give more details if anyone need help.

« Last Edit: September 14, 2020, 05:14:38 am by RedArrow »


  • The Oxy-genuine article
  • El Toro
  • ****
  • Posts: 380
  • Giving you some breathing space.
Re: Crashed LS420D8A8
« Reply #1 on: September 11, 2020, 12:27:34 am »
Try the LSUpdater to flash the firmware