Author Topic: {Guide}How to get SSH access and change transmission client password on LS520D  (Read 1044 times)

Gogoli

  • Calf
  • *
  • Posts: 10
Hello

After struggling to find a way to change transmission password because the default one is empty I found the way to change that password...
My box is a Buffalo LS 520D with firmware 4.50

First, we have to enable ssh to get root access witch is very simple using acp commander witch all of you are familiar with
Code: [Select]
java -jar acp_commander -jar -t yournasiphere -ip yournasiphere -c "/etc/init.d/ssh.bak start"
The root password is empty but in case it isn't just use this command to change the root password to something you want
Code: [Select]
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw Youradminpassword -c "(echo newrootpass;echo newrootpass)|passwd"
Third, you have to use WinSCP windows program and login through sftp with your ssh credentials and navigate to:
Code: [Select]
/etc/transmission-daemon/settings.json
After, write the rpc-password in the /etc/transmission-daemon/settings.json file, in double-quotes

At the end connect through putty with ssh details and run this command
Code: [Select]
/etc/init.d/transmission-daemon reload
Voila your trasmission password was changed successfully



1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 829
  • There's no problem so bad you cannot make it worse
Nice!

Does the setting stay in place if you reboot?

Gogoli

  • Calf
  • *
  • Posts: 10
Yes 100%...I already tried to reboot it and even turned off my NAS and the password didn't reset....After reboot or reloading the demon the password is same, just the password inside the settings.json is being hashed automatically by the system.


The trick for this was to not run those commands while demon is stopped!

« Last Edit: August 20, 2020, 10:28:30 am by Gogoli »

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 829
  • There's no problem so bad you cannot make it worse
I noticed they did an overlay for /etc but didn't realize it was to make it RW. That makes sense, otherwise things like passwords also wouldn't be persistent.

That opens up some interesting (and dangerous) possibilities.

Gogoli

  • Calf
  • *
  • Posts: 10
Dangerous for me is equal to freedom

To earn full freedom you have to risk

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 829
  • There's no problem so bad you cannot make it worse
were you able to log in directly by connecting to root@<nas_ip> or did you have to connect as admin and then switch user?

Gogoli

  • Calf
  • *
  • Posts: 10
As root@NAS
They only stopped the ssh and renamed it to ssh.bak
Starting it give you root access by loging in as root

The only problem is that there isnt much you cant do with it as everything is disabled,even no text editor installed.At least I edited the trasmission file to set the password through sftp and using root login