Author Topic: BuffaloNAS.com registration fails with Linkstation LS520D. Router is BT Hub 5  (Read 414 times)

Donach

  • Calf
  • *
  • Posts: 1
I recently bought a Buffalo Linkstation LS520D as a NAS. It works fine on my home network but every time I try to register a name on www.buffaloNAS.com it fails, giving an error message of 'Could not get data'. Registering it is necessary to enable the remote access apps to work. I've spent most of the week back and forth with the Buffalo helpdesk but we just can't work out what the problem is. It sends this message whether I try to register a name that's already in use or one that's been verified as not in use yet.

I've tried putting the NAS in a DMZ and temporarily disabling the BT Hub firewall as well as using UPnP or not, using HTTPS or not, and making various Port Forwarding rules. I also reinstalled the firmware and repeatedly reset the Linkstation settings.

I'm using a BTHub 5 on Infinity 2, so FTTC. I tried to swap in another router but that didn't work as it didn't have a VDSL modem in it.

If I enter my external IP address with :9000 appended I can get into it, but this is far from an ideal solution, particularly on a mobile phone. However, this shows that the NAS is accepting connections from the outside, so it appears that something is stopping the NAS from communicating out to the buffaloNAS server. I also can access www.buffaloNAS.com from my other devices.

Has anyone got any ideas what the problem could be or something else I could try?