Author Topic: LS220 Email Notification SOLVED  (Read 1483 times)

burt

  • Calf
  • *
  • Posts: 29
LS220 Email Notification SOLVED
« on: April 15, 2020, 02:47:52 pm »
Hi,

Anyone reading this post get this to work? If you did please let me know.

Now after a complete reprogramming my LS seems to be working normally except for: Email notification.

This is not a major issue with me. It's aggravating that it doesn't work. I have searched the forum and found quite a few threads but nothing that seemed like a solution. In my last email with Buffalo Tech Support to tell them my NTP issue had been resolved I mentioned the Email notification problem.
Here is their response:
Quote
Unfortunately we do not have specific configuration settings for each email server that can be used to receive email notifications.
Each provider should have the specific settings, while I am unable to provide links outside of our website a search in google for ďatt SMTP settings/ports" does yield results.
With these settings being dictated by the email provider there is no way we can provide assistance for this as you are trying to connect to their email server with the information they provide.
The only settings that could affect this would be to make sure the unit has properly configured DNS settings and the unit has access to the internet.

I sent the following to Buffalo:

SMTP Server Address:outbound.att.net
SMTP Port:465                                             (I have tried various others)
Authentication Type:LOGIN
POP3 Server Address:inbound.att.net
POP3 Port:995                                             (Others tried here as well)
SSL/TLS:SSL/TLS
Username:bxxxx@sbcglobal.net
Password:******************
Subject:LinkStation Status Report
admin      bxxxx@sbcglobal.net    Users

I also tried with a gmail account. Tried with less strict authentication rules which didn't work either.

Any advice will be greatly appreciated.
Thanks,
Herb



« Last Edit: April 22, 2020, 02:33:17 pm by burt »

Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220 Email Notification
« Reply #1 on: April 15, 2020, 04:01:31 pm »
That's true, Buffalo would not have such settings, since each ISP is different.  You would have to get the settings from your AT&T ISP.

I have no idea what 'less strict authentication rules' you are talking about on gmail.

For gmail, you have to login to gmail > click your acct on top right > manage your acct > security > use less secure app access
Then, on the nas - under email notification

Here are the gmail settings, these work for me:

SMTP server: smtp.gmail.com
SMTP port: 465
sender youremail@gmail.com
authentication type: login smtp-auth
pop3 server - grayed out
pop3 port- grayed out

SSL/TLS: SSL/TLS
username: youremail@gmail.com
password: yourpassword

recipients: add a buffalo user acct that has a gmail acct attached to it in the user settings.

If these settings don't work, your ISP may be blocking the access.

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220 Email Notification
« Reply #2 on: April 15, 2020, 04:02:02 pm »
kane88 is on the right track, though rather than disabling app specific tokens I'd recommend using one instead.

Looks like att may have recently made them mandatory, take a look at this:
https://www.att.com/support/article/email-support/KM1240308

Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220 Email Notification
« Reply #3 on: April 15, 2020, 04:22:28 pm »
It doesn't work with gmail, unless that setting is changed.  That much I do know.  I forget where I read about it so long ago- probably here at the forum somewhere.

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220 Email Notification
« Reply #4 on: April 15, 2020, 06:09:46 pm »
You can setup per-app credentials with gmail. I forget what they are actually called but Iím using them for my current monitoring setup.

burt

  • Calf
  • *
  • Posts: 29
Re: LS220 Email Notification
« Reply #5 on: April 17, 2020, 11:38:45 am »
recipients: add a buffalo user acct that has a gmail acct attached to it in the user settings.

Do you mean I have to get an account name from Buffalo? Or is this the user name I enter in Navigator? Or something else?

Under "File Sharing" there is a "users list" which has "guest and "admin"     [  one of these?  ]

Under Email Notifications Recipient(s)*:  I see...
 
Name            Recipient(s)                          Class
 admin          xxxx@sbcglobal.net               Users

Basically I'm not sure what you mean.
Thanks for the help.
Herb

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220 Email Notification
« Reply #6 on: April 17, 2020, 11:53:14 am »
Take a look at the link I posted earlier.

AT&T changed how there POP/SMTP/IMAP access works (to be more secure). You need to make changes both in your sbcglobal account and on your Linkstation to get it working again.

burt

  • Calf
  • *
  • Posts: 29
Re: LS220 Email Notification
« Reply #7 on: April 17, 2020, 01:06:09 pm »
Take a look at the link I posted earlier.

AT&T changed how there POP/SMTP/IMAP access works (to be more secure). You need to make changes both in your sbcglobal account and on your Linkstation to get it working again.

I have OAuth set up on one at&t account and a gmail account, that's the new thing.
Don't see how that would help here as Buffalo does not have OAUTH as a choice.
Tried using the secure key instead of the password with no success.
Still pretty much of a blind alley in my opinion.
It's good that I'm old and retired and can waste time on things like this. It does keep me amused most of the time.
Thanks for the help.
Herb



1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220 Email Notification
« Reply #8 on: April 17, 2020, 01:13:50 pm »
Itís been a while since I looked at it, but i believe for gmail the equivalent is just a separate per app password that you generate. I didnít look too closely at the att implementation but am under The impression most such systems use a separate username/password so that a standard client still works but your real password is kept separate.
.


Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220 Email Notification
« Reply #9 on: April 18, 2020, 12:52:16 am »
recipients: add a buffalo user acct that has a gmail acct attached to it in the user settings.

Do you mean I have to get an account name from Buffalo? Or is this the user name I enter in Navigator? Or something else?

Under "File Sharing" there is a "users list" which has "guest and "admin"     [  one of these?  ]

Under Email Notifications Recipient(s)*:  I see...
 
Name            Recipient(s)                          Class
 admin          xxxx@sbcglobal.net               Users

Basically I'm not sure what you mean.
Thanks for the help.
Herb

It looks like you've got the buffalo admin acct setup for what I am talking about.

On the buffalo console under file sharing > users 

go to the username that you use to access the nas
there is an email field.  put in the email address you want to use to get the notifications on that line.

Then on the email notifications screen, you just add the buffalo username- as it uses the email that is set for (tied to) that user acct.



burt

  • Calf
  • *
  • Posts: 29
Re: LS220 Email Notification
« Reply #10 on: April 18, 2020, 05:52:33 pm »
Thanks Kane88,

I think I have now given up.

Unless some new light comes on I've quit trying.

Herb

Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220 Email Notification
« Reply #11 on: April 18, 2020, 06:12:16 pm »
That's unfortunate.  The gmail settings I mentioned should have worked for sure.  My guess is your ISP is blocking the access that's needed for the messaging.

I don't use AT&T or SBC, so I have no clue how they do things.

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220 Email Notification
« Reply #12 on: April 18, 2020, 07:29:53 pm »
ISP interference is vanishingly unlikely, This isnít like running your own unauthenticated mail server (which would get rejected in various ways). This connection uses the same ports/protocol your phone uses to connect (for example).

There are a number of places it could be going wrong I can think of from dealing with similar things elsewhere. I wonder if there is a log that you could look at for this. Assuming it isnít just a configuration issue my next guess would be something ssl/certificate related.

gzt

  • Calf
  • *
  • Posts: 4
Re: LS220 Email Notification
« Reply #13 on: April 22, 2020, 06:11:40 am »
Using gmail account and gmail smtp works well for my linkstation ls210d. As said by some above, you only need to activate the use app passwords feature in your google account (you previously need to activate the 2-way stuff too). This will generate a token as your password (dont use your gmail password). Also, remember to set your username as xyz@gmail.com (important to have the @domain part).

Other option is to use your ISP smtp without authentication? I'm in the UK and mine works that way too.

burt

  • Calf
  • *
  • Posts: 29
Re: LS220 Email Notification
« Reply #14 on: April 22, 2020, 02:32:48 pm »
This did not work because of a problem with MAC binding to IP address with my router.
I have a RG (Residential Gateway) for my ADSL service from AT&T. That feeds an Archer C7 router that provides wireless and wired ports. It allows binding of MAC addresses with IP addresses. As I map several drives in Windows is is very handy having them at fixed addresses.
My error was I mistook an 'B' for a '8' in the LS220's MAC. It worked if I select DHCP but not when assigned a static IP to the NAS.
Fixed this and everything seems to be working including the email notifications. gmail would not work. Got message from Google that a non-secure device had tried to access gmail. Changed to an AT&T email account and it worked.
Herb