Author Topic: LS220D Sleep Timer Time Zone SOLVED  (Read 1765 times)

burt

  • Calf
  • *
  • Posts: 29
LS220D Sleep Timer Time Zone SOLVED
« on: February 24, 2020, 02:39:55 pm »
These are my settings for a Buffalo LS220D in NAVIGATOR ->Management -> Name/Time/Language -> Time -> Edit

********************************  (The firmware is up to date.)

Date/Time Source:    X means Selected
X Enable
   NTP IP Address*: ntp.jst.mffeed.ad.jp
         X Use Default NTP Server
   NTP Synchronization Frequency: Every 3 hours
Time Zone:
(UTC-05:00) Eastern Time (US & Canada)

After pressing "OK"
Get error message:
Failed to sync with NTP server. Settings were saved.

**************************************

Then selecting Name/Time/Language -> Time -> Edit
Shows: Date/Time Source: Enabled    (02/24/2020 20:14:30)
SHOULD BE:  (15:14:30)     In ERROR by 5:00 hours.
This is causing a problem with the "Sleep Timer" it's OFF when it should be ON and vice versa.

**************************************

So I tried
Time Zone:
(UTC-10:00) Hawaii
Shows: Date/Time Source: Enabled    (02/24/2020 15:20:01)
Which is what it should be.

********************************************

Three Questions:

1. Why do I get the error message:
      Failed to sync with NTP server. Settings were saved.

2. Why do I have to set time zone to UTC -10:00 when I am in the Eastern US time zone of UTC -05:00

3. Should I be selecting a different time server? If so which one?

Thanks for any input.


« Last Edit: April 22, 2020, 02:29:22 pm by burt »

As3nd0r

  • Tatanka
  • **
  • Posts: 55
Re: LS220D Sleep Timer Time Zone
« Reply #1 on: February 25, 2020, 03:00:31 am »
Did you check your network settings? Is there a valid dns entry?
Aspirat primo Fortuna labori
Me duce tutus eris

oxygen8

  • The Oxy-genuine article
  • El Toro
  • ****
  • Posts: 377
  • Giving you some breathing space.
Re: LS220D Sleep Timer Time Zone
« Reply #2 on: February 25, 2020, 04:29:28 am »
1) Set the correct time and timezone manually
2) activate ntp

I have had the following problem:
The nas can not sync if the timedifference is to big

burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #3 on: February 25, 2020, 07:14:54 pm »
Did you check your network settings? Is there a valid dns entry?

Forgive my ignorance but I don't know what you mean by this.

The NAS has an IP address of 192.168.X.X and is usable on the local LAN.

I can get to the settings in Navigator. Must be missing something here.

I'm assuming you mean something else.

Also I'm assuming this has nothing to do with FTP access to the files.

Thanks,
Herb

As3nd0r

  • Tatanka
  • **
  • Posts: 55
Re: LS220D Sleep Timer Time Zone
« Reply #4 on: February 25, 2020, 10:33:35 pm »
no worries, Right-click on the Linkstation icon in NasNavigator and open settings. Go into advanced settings - IP address and check if DHCP is enabled.

If DHCP is disabled, check the entries for gateway and primary and secondary DNS. If those are invalid or blank, your LinkStation will be working fine locally but won't be able to connect to anything outside your local network (including NTP server). Gateway = how do I get out of the local network. Typically your routers IP.  DNS = what IP is behind abcdefg.com so I know where to go. Can be any valid DNS, i.e. your providers, google (8.8.8.8), 1.1.1.1 etc. 

If DHCP is enabled, network settings are unlikely to be the issue here. (unless of course all DHCP clients have internet connectivity issues and the ones that are working are configured manually).
Aspirat primo Fortuna labori
Me duce tutus eris

burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #5 on: February 26, 2020, 08:27:38 am »
no worries, Right-click on the Linkstation icon in NasNavigator and open settings. Go into advanced settings - IP address and check if DHCP is enabled.

If DHCP is disabled, check the entries for gateway and primary and secondary DNS. If those are invalid or blank, your LinkStation will be working fine locally but won't be able to connect to anything outside your local network (including NTP server). Gateway = how do I get out of the local network. Typically your routers IP.  DNS = what IP is behind abcdefg.com so I know where to go. Can be any valid DNS, i.e. your providers, google (8.8.8.8), 1.1.1.1 etc. 

If DHCP is enabled, network settings are unlikely to be the issue here. (unless of course all DHCP clients have internet connectivity issues and the ones that are working are configured manually).

You were correct DHCP was disabled.
When I click on Enable I get the following message:
Default gateway and DNS server addresses cannot be changed because DHCP is enabled for LAN port 1.

Under Network Settings this appears but is grayed out:  Default Gateway Address:   192.168.0.1  (This is address of router)

Querying of the time server (which I set to pool.ntp.org) worked.

However the address of the LS220 changed from 192.168.0.125  to 192.168.0.104
I assume this is due to DHCP being enabled.

Because I map this drive in windows explorer I would like to keep it at 192.168.0.125

Is there anyway to keep the LS220 address at an unchanging address like 192.168.0.125 ?

Many thanks, you have been very helpful.

Herb


burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #6 on: February 26, 2020, 09:55:02 am »
I believe I have it working with a fixed address for the LS220. This is what I did.
Open Navigator ->Search Again -> Properties -> IP Address
Uncheck: Use DHCP , RenewIP address
Enter the following:
IP Address 192.168.0.125
Sub Mask   255.255.255.0
Default gate 192.168.0.1
Hit OK

Still in Navigator:
Menu -> Properties -> Open Settings -> Advanced Settings -> Network -> IP Address List
Double click LAN Port 1
Enter the following:
Default gate 192.168.0.1
Primary DNS Server 208.67.222.222            (use whatever you want these are OpenDNS)
Secondary DNS Server 208.67.220.220        ( Google is 8.8.8.8 or 8.8.4.4)
Hit Close

In my Archer C7 router I entered this:   DHCP -> Reserved Addresses place:
       MAC Address          Reserved IP
 84-AF-EC-XX-D8-xx  192.168.0.125  Enabled   (MAC & IP as appropriate)

Comments or suggestions are welcome.
All I can say is it seems to be working okay.

Again thanks for the help.

Herb



As3nd0r

  • Tatanka
  • **
  • Posts: 55
Re: LS220D Sleep Timer Time Zone
« Reply #7 on: February 27, 2020, 05:28:48 am »
That should work fine :)
Aspirat primo Fortuna labori
Me duce tutus eris

burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #8 on: April 07, 2020, 06:29:56 pm »
Reviving old thread here:
The time has stopped working. In my last post, shown below, it apparently worked until the change to DST. Now I get a message it cannot sync to the time sever.
I use the SLEEP TIMER to shut the LS220 OFF for about 8 hours every day. If the time is incorrect the LS220 shuts off when I need to use it because of the apparently incorrect time.
I have also tried to use the local time which is synced to time.windows.com which is correct. However the LS220 seems to have the same problem with that.

I am coming to the conclusion that A.) the TIME function of my LS220 is buggy or B.) the LS220 SLEEP TIMER is buggy.

Idea or suggestions welcome.
Thanks in advance.
Burt


From Feb 2020:
I believe I have it working with a fixed address for the LS220. This is what I did.
Open Navigator ->Search Again -> Properties -> IP Address
Uncheck: Use DHCP , RenewIP address
Enter the following:
IP Address 192.168.0.125
Sub Mask   255.255.255.0
Default gate 192.168.0.1
Hit OK

Still in Navigator:
Menu -> Properties -> Open Settings -> Advanced Settings -> Network -> IP Address List
Double click LAN Port 1
Enter the following:
Default gate 192.168.0.1
Primary DNS Server 208.67.222.222            (use whatever you want these are OpenDNS)
Secondary DNS Server 208.67.220.220        ( Google is 8.8.8.8 or 8.8.4.4)
Hit Close

In my Archer C7 router I entered this:   DHCP -> Reserved Addresses place:
       MAC Address          Reserved IP
 84-AF-EC-XX-D8-xx  192.168.0.125  Enabled   (MAC & IP as appropriate)


Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220D Sleep Timer Time Zone
« Reply #9 on: April 07, 2020, 10:23:47 pm »
Because I map this drive in windows explorer I would like to keep it at 192.168.0.125

Is there anyway to keep the LS220 address at an unchanging address like 192.168.0.125 ?

You would need to set a static IP, which you have done.

Also, you can map drives with the NAS hostname (machine name), instead of the IP.  That probably would be better anyway, it would completely avoid IP address changes.


As to the time problems:
Given the various bugs that exist with the LS220 series, I would not be surprised if one or both of these things are because of firmware bugs.

I am using that same time server: ntp.jst.mffeed.ad.jp with automatic settings on my terastation, and have not encountered that issue with the time server.  I don't use the sleep modes.


What is the DHCP pool range for your archer router?
The reservation sounds fine, but I would suggest to use a static IP address that is not in the pool range.

My router uses 192.168.x.100 to 192.168.x.150 for DHCP.

I assign static IPs to my terastations that are outside of that 100 to 150 range.
Ethernet Frame size is at the default: 1500 bytes
Gateway - router internal address
DNS - router internal address

I wonder if your NAS is having problems resolving DNS.
Some DNS servers don't like 3rd party DNS queries (if a host is not part of a network, it won't resolve the address.  The DNS server will just reject the request of the outside host).
Try changing the DNS IP to your archer gateway IP, and set the time server to automatic again with the sleep timer off as a test.  This way you can at least see what is going on with the time server.

If it works, turn the sleep timer on.

I'm surprised the sleep timer would start acting up just because of daylight time.  Maybe getting the time server back on automatic settings- will resolve that.

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 740
  • There's no problem so bad you cannot make it worse
Re: LS220D Sleep Timer Time Zone
« Reply #10 on: April 08, 2020, 08:25:29 am »
By chance, have your region's DST dates changed in the last ~10 years?

I believe NTP won't adjust the time if it gets to far out of sync. I believe you can disable NTP, set the correct time, then re-enable NTP to get things syncing again.

burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #11 on: April 08, 2020, 03:52:35 pm »
Kane 88

As to the time problems:
Given the various bugs that exist with the LS220 series, I would not be surprised if one or both of these things are because of firmware bugs.

I am using that same time server: ntp.jst.mffeed.ad.jp with automatic settings on my terastation, and have not encountered that issue with the time server.  I don't use the sleep modes.
Sorry I did not mention this. I never got this to work without setting time zone to UTC -10 Hawaii. I live in Ohio.
I use(d) pool.ntp.org and could set the TZ to UTC -5 which is correct. Buffalo tech suggested this server.



What is the DHCP pool range for your archer router?
The reservation sounds fine, but I would suggest to use a static IP address that is not in the pool range.

My router uses 192.168.x.100 to 192.168.x.150 for DHCP.  Mine is 192.168.x.100 to 192.168.0.199.  Curious why you want to be out of the range.

I assign static IPs to my terastations that are outside of that 100 to 150 range.
Ethernet Frame size is at the default: 1500 bytes
Gateway - router internal address
DNS - router internal address

I wonder if your NAS is having problems resolving DNS.  Changing this had no effect same error.
Some DNS servers don't like 3rd party DNS queries (if a host is not part of a network, it won't resolve the address.  The DNS server will just reject the request of the outside host).
Try changing the DNS IP to your archer gateway IP, and set the time server to automatic again with the sleep timer off as a test.  This way you can at least see what is going on with the time server.

If it works, turn the sleep timer on.

I'm surprised the sleep timer would start acting up just because of daylight time.  Maybe getting the time server back on automatic settings- will resolve that.
I'm not sure that it happened at that time. I didn't start noticing the problem for several days or maybe a week after the change.

Thanks

burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #12 on: April 08, 2020, 03:55:39 pm »
By chance, have your region's DST dates changed in the last ~10 years?

I believe NTP won't adjust the time if it gets to far out of sync. I believe you can disable NTP, set the correct time, then re-enable NTP to get things syncing again.

DST times have not changed recently that I am aware of.
I also believe the time has to be reasonably close and I have made sure that the time is correct within a minute or so. That produces no joy.

Thanks

Kane88

  • Buffalo
  • ***
  • Posts: 161
Re: LS220D Sleep Timer Time Zone
« Reply #13 on: April 09, 2020, 02:55:44 am »
Don't worry with the DHCP reservation.  It's fine.  I was just pointing out that a reservation isn't needed if you gave the NAS an IP like 192.168.x.40 or .240 for your setup, since neither are in your DHCP pool.


even with the pool.ntp.org working ok, I would assume the sleep timer should run fine.  That's gotta be a firmware bug.
if not then maybe the system isn't updating every 3 hours, I only sync mine once per day.
or maybe the firmware won't play nice w/sleep, unless using the default ntp server.


It is odd you can get to pool.ntp.org, but not the other one.  It's still possible the default .jp server isn't resolving for whatever reason.

I only mentioned DNS because that Open DNS and other settings you noted recently- don't work for everyone.
I wouldn't use 3rd party addresses for DNS, unless I know my ISP allows it...
https://support.opendns.com/hc/en-us/articles/227988727-How-can-I-tell-if-my-ISP-Allows-Third-Party-DNS-Providers-


going with the idea that maybe it won't play nice w/o defaults:
what about this, using the numeric for the NTP default?
ntp.jst.mfeed.ad.jp (Default Server) of 210.173.160.87

http://forums.buffalotech.com/index.php?topic=10346.0



burt

  • Calf
  • *
  • Posts: 29
Re: LS220D Sleep Timer Time Zone
« Reply #14 on: April 11, 2020, 05:17:36 pm »
Here the third latest "suggestion from Buffalo: Do a firmware update from 1.73 to 1.74: Did absolutely no good.

Here is the second latest: Try clearing the cache to your browser, then once this is done try changing the DNS to the suggested Google DNS address, then attempt to sync to your NTP server. If this does not work try using a different browser. All of the above improved nothing.

Here is the latest: However if this is a case of firmware corruption these is a 100% clean cut way of resolving it, however it does destroy any data on the unit.  Please make sure any critical data is backed up before trying the steps that have been attached to this email. A pdf file with instructions was attached. I wold attach it but I don't see how.

i am in process of doing this now.
Anyone have an approximate time for the "Create RAID Array" to complete? The window that is open doesn't seem to update either the % progress or time remaining numbers. I am really impressed with the fine quality of the Buffalo software.

Thanks for any information.

Herb