Author Topic: Terastation 5410D Domain Issue  (Read 138 times)

bpiela

  • Calf
  • *
  • Posts: 1
Terastation 5410D Domain Issue
« on: February 15, 2020, 02:14:09 pm »
I had a problem today with my Terastation 5410D on my domain.  I joined my domain two years ago with this 5410D.  The NAS is really just a storage area for local server backups so I don't really need to use alot of Access Restrictions.  The volumes are only mounted on 3 servers.  This morning I saw that the shares were no longer accessible.  The username or password is incorrect for the user owning the SMB mount.  I opened a ticket with Buffalo tech support and we found that if I mapped the drive using the IP address of the Terastation instead of its hostname, it would map the drive successfully.  If I used the hostname, it would fail.  I was able to open a Command Prompt window and ping the hostname and it resolved properly and pinged the correct IP address.  The username that mapped the drive did not have its password changed.  I was able to resolve the problem by rejoining the domain from the Terastation.  I went to Network -> Workgroup/Domain -> Settings and clicked on Edit, typed in the domain admin name and password and rejoined the domain.  Now it works.  Afterwards, I made sure the Terastation was accessible as it was in the past on each server and restarted my backups.  The weird thing I saw was that the two Windows 2012 servers were the ones that had issues.  There is another older Windows 2008 server and it had no issues.  Backups completed successfully last night.  The backup jobs of the three servers typically happen at the same time so it wasn't that the old server completed its backups first and then the issue happened.  No, the issue was never experienced on the Windows 2008 server.  My question is this.  Is the older server using a different version of SMB?  Is it possible that I hit some kind of bug with the Terastation's SMB implementation?  Are there logs anywhere that I could look at?  The Terastation is running the latest firmware, 4.54-0.05, which was updated on 1/3/2020.

Kane88

  • Buffalo
  • ***
  • Posts: 141
Re: Terastation 5410D Domain Issue
« Reply #1 on: February 17, 2020, 06:29:28 pm »
Quote
My question is this.  Is the older server using a different version of SMB?
Yes
Win 2008 Server Uses SMB 2.1
Win 2012 Server Uses SMB 3.0

Quote
Is it possible that I hit some kind of bug with the Terastation's SMB implementation?
 
Maybe.  I don't know.  I forget what versions of SMB the Terastations support out of the box.  Something doesn't play nice between Buffalo and MS in my experience.

I can't say for Windows 2012 and AD, but I do know with Windows 10, these Terastation 3400 and 5400 series NAS devices, they don't like having multiple connections with the same account- with different machines.  Why?  I have no idea.

I'm not using AD with my units, I use an account created on the terastation itself.  After rebooting a Windows 10 PC, I wind up running my drive map scripts sometimes 3 or 4 times, before they will map.  The scripts will often throw a 'Multiple connections to a server or shared resource by the same user' error.  Why?  I have no idea- as they are authenticating with the Buffalo/Linux account- not a MS account.  I shouldn't be seeing such an error.

As to your case:
I assume you're authenticating with a Windows AD account to map these shares on the servers themselves, correct?  Can you show us your net use command(s) that you're doing for the mapping?  And any more detail specifics on the error(s) you get would help.

I would try creating two more AD accounts, one for each win 2012 machine to do their mappings - and see if you get the same issue.

If you don't get the same error, then I'd say this is more of an issue w/multiple connections- similar to what I just mentioned.