Author Topic: LS210D update  (Read 402 times)

farcusnz

  • Calf
  • *
  • Posts: 18
LS210D update
« on: February 07, 2020, 04:04:26 am »
I have a Linkstation LS210D running firmware 1.70-0.01
If I click on the web interface Settings > Management > Update, I get the message "This LinkStation is using the latest firmware"

However, If I click (from the web interface) "downloads"
I can see that firmware 1.74 was released Feb 5 2020

As I am using Linux (openSUSE) I cannot download and use either the windows or maxos firmware updater.

Why is the nas interface itself failing to locate the updated firmware?

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 550
  • There's no problem so bad you cannot make it worse
Re: LS210D update
« Reply #1 on: February 07, 2020, 06:25:41 am »
Iím not sure why this happens but it happens on other models too.

The windows firmware updater works in linux using WINE.

farcusnz

  • Calf
  • *
  • Posts: 18
Re: LS210D update
« Reply #2 on: February 07, 2020, 11:18:09 pm »
thanks. I'll give it a try via wine

farcusnz

  • Calf
  • *
  • Posts: 18
Re: LS210D update
« Reply #3 on: February 08, 2020, 06:14:42 pm »
always been a bit paranoid about running a firmware updater using wine - but it actually worked flawlessly.
All up to date now.
Thanks again

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 550
  • There's no problem so bad you cannot make it worse
Re: LS210D update
« Reply #4 on: February 08, 2020, 07:12:10 pm »
I was too at first but I've used it for years and it's always worked great.

If you're interested in Linux there are some additional resources you may be interested in:

If you ever need debug mode I've got some notes about allowing that menu to display when using wine:
https://buffalonas.miraheze.org/wiki/Enable_Debug_mode

If you'd like you can run Debian on these devices rather than the stock firmware:
https://github.com/1000001101000/Debian_on_Buffalo

If you ever need shell access while running the stock firmware there is a tool for that:
https://github.com/1000001101000/acp-commander