Author Topic: Reading drives after ls duo fail  (Read 233 times)

LearningCurve

  • Calf
  • *
  • Posts: 8
Reading drives after ls duo fail
« on: December 30, 2019, 06:27:08 am »
Hi,

My ls-wxl has just died, blue light started flashing and will not get past that so I have no access to it at all.

I have removed the drives both of which seem fine, and attached them to a linux PC.

The drives are Samsung HD502HI.

I ran gparted and both drives gave the same information as follows;

Partition         Name       Filesystem    Size         Used   Unused   Flags

/dev/sde1      primary   linux-raid     976.55MiB      -          -       msftdata
/dev/sde2      primary   linux-raid         4.77GiB      -          -       msftdata
/dev/sde3  !   primary   unknown         512.00B      -          -       msftdata
/dev/sde4  !   primary   unknown         512.00B      -          -       msftdata
/dev/sde5      primary   linux-raid     976.56MiB      -          -       msftdata
/dev/sde6      primary   linux-raid     451.53GiB      -          -       msftdata
unallocated                  unallocated      7.55GiB      -          -       msftdata

I cannot mount any partitions to read them and copy data from them.
I could presumably delete all the partitions and reused the drives as they do not appear to have any problems.

As these are linux-raid partitions I wondered if it would be possible to use the linux software raid mdadm software to access them.
If this is possible could anyone let me know how I would do this and indeed if there is any other way.

Your help is appreciated in advance,
many thanks
Mike

1000001101000

  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 612
  • There's no problem so bad you cannot make it worse
Re: Reading drives after ls duo fail
« Reply #1 on: December 30, 2019, 07:38:46 am »
You should be able to. I posted some notes on how to do this in a recent post:
https://forums.buffalotech.com/index.php?topic=32858.msg101343#msg101343

LearningCurve

  • Calf
  • *
  • Posts: 8
Re: Reading drives after ls duo fail
« Reply #2 on: December 30, 2019, 12:16:35 pm »
Hi 1000001101000,
thanks for the very prompt reply.
I have obviously been searching elsewhere too.
I have found roughly the same solution on a ubuntu forum with the --scan etc. and it seems to have worked for one or two people.
I am about to set up a replacement server running lubuntu as I've had several problems.
I do like buffalo products and have had a variety over the years and this linkstation has been great until the day it suddenly decided to give up the ghost.
Once I get this server up and running, I will give this a go and build a new replacement raid.
Many thanks for your help,
Mike