Author Topic: Buffalo Nas not working - read disk with a mac?  (Read 1362 times)


  • Calf
  • *
  • Posts: 11
Buffalo Nas not working - read disk with a mac?
« on: September 12, 2019, 12:45:54 pm »
Hi guys,

I have this 6 years old buffalo link station duo, with two disks configured in mirroring (RAID1).
The nas was not responding no more on the network, so i tried to access via browser, no answer.
Tried a network scan i can see the ip is, tried to access that via browser - no answer
Pinging is working.
Tried to shut down, tried to remove the disks, nothing works.

Last tried I've installed NasNavigator2, can't see the NAS.
So I tried to make a reset using the procedure, turning it off, holding the function button, turning it on, led was blinking, pressed the function button again and waited the NAS to woke up. Nothing happened.

The NAS without the disks is blinking 7 times red, with the disks inside it have the blue light on.
NasNavigator 2 can't see the NAS in any situation, so now what are the chances?

First of all I do need to read the data on one of the two disks (they should got the same content), can I do that with an external USB HDD reader and UFS Explorer professional recovery installed?
or do I need another software?

ALSO, is there a way to repair/hard reset the NAS or I have to trash it and buy another one?
In that case, can I buy an empty NAS and put the disks I have in it?

Thank you


  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 932
  • There's no problem so bad you cannot make it worse
Re: Buffalo Nas not working - read disk with a mac?
« Reply #1 on: September 12, 2019, 01:43:15 pm »
the data will be stored in an XFS filesystem within a software raid array.

The easiest way to access the data is to attach the disk to a system running linux, start the array (if it doesn't automatically) and mount the filesystem. I don't know if there is a native way to do that in OSX or not.

You can transfer disks from one device to another if they are the same model. If there's something physically wrong with the device that may help but it's more likely an issue with the drives/boot partition than the device itself.

They pinned a post to the top of the forum with instructions on how to "start over" with an empty the device. The name is a little confusing because TFTP isn't the only option. That post can be found here:


  • Calf
  • *
  • Posts: 11
Re: Buffalo Nas not working - read disk with a mac?
« Reply #2 on: September 13, 2019, 04:51:30 am »
Thank you for your answer.
I can tell you that UFS Explorer professional recovery can read the data, but it's a licensed software that cost 599$.
It exists a lite version (only for windows) called UFS Explorer standard access, that costs 21$, i guess i'm going for that.
I'm not able to mount linux somewhere and using it, too much pain for me.

The next battle will be, how I do recover the functionality of the NAS and the disks (i can format them cause I will have saved already the data on them).