Author Topic: Cannot access LS-CHL from internet  (Read 4187 times)

Minolfan

  • Calf
  • *
  • Posts: 10
Cannot access LS-CHL from internet
« on: August 05, 2009, 09:40:06 am »
   

I just setup my LS-CH1.0TL. I can do webaccess using the computers on local network, but cannot from the internet. The browser gave me the error "the web page cannot be displayed". My settings are as follows:

 

On NAS - webaccess

auot-configure firewall: disabled.

External port: 9000

 

On NAS - network IP address setting

DHCP: enabled (or disabled) I tried both

Primary IP address: my NAS IP address

subnet mask: 255.255.255.0

Default gateway address: my router IP address

Primary DNS server: my router IP address

Secondary DNS server: (blank)

 

On router (D-link DIR-628), Port forwarding:

IP address: my NAS IP address on LAN

TCP: 9000, schedule - always

UDP: 9000, inbound filter - always all

 

Did I do something wrong or are there any other settings I need to do on either NAS or router?

 

Thanks in advance for your help.


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #1 on: August 05, 2009, 03:52:14 pm »

PM me your buffalonas name, I will check that out for you.  In the meantime go to canyouseeme.org to see if the ports are open.

 

Also do you have cable or DSL?

Message Edited by PCPiranha on 08-05-2009 03:52 PM

Minolfan

  • Calf
  • *
  • Posts: 10
Re: Cannot access LS-CHL from internet
« Reply #2 on: August 06, 2009, 12:37:25 am »
   This is a test. I typed in quite a bit of reply. When I hit submit post, I got a message the link was valid. So I am testing it with a short message.

Minolfan

  • Calf
  • *
  • Posts: 10
Re: Cannot access LS-CHL from internet
« Reply #3 on: August 06, 2009, 12:47:04 am »
   OK, I saw my reply test. Now I will try again for real reply. Were you asking for my buffalonas login name? How do I PM you? I did go to canyouseeme.org and tested all the ports listed on the website. None of them was open. However, the IP address displayed was the one for internet connect provided by ISP through DHCP, not my router IP address. Do I need to setup this IP address somewhere in my NAS or router (router sees it)? I use optical fiber through a local ISP called fibersphere. Should I request special setup from it? Thanks.

PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #4 on: August 06, 2009, 02:42:29 pm »
Give me the model number of your modem and in order to PM me, click on my name.  This will bring up my profile and you will see a link in the upper right to send a private message.

PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #5 on: August 06, 2009, 10:00:48 pm »
PM me with your wan IP as well.  It seems farfetched but it is also possible that your ISP blocks that port.

PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #6 on: August 08, 2009, 02:23:24 pm »
It looks like it should work with the info you have provided.  If it works locally, then the Linkstation is functioning properly. Where did you get the WAN IP that you PMed me?

Minolfan

  • Calf
  • *
  • Posts: 10
Re: Cannot access LS-CHL from internet
« Reply #7 on: August 09, 2009, 08:14:21 pm »
   Unfortunately it is not working. I PM'd you regarding where I got WAN IP. What problem could it be. Any suggestion of further trouble shooting?

PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #8 on: August 10, 2009, 04:56:43 pm »
ok, didn't realize that you got it from canyouseeme, that makes sense.  What is the WAN ip in your routers web interface?

Minolfan

  • Calf
  • *
  • Posts: 10
Re: Cannot access LS-CHL from internet
« Reply #9 on: August 11, 2009, 01:12:17 pm »
   

The WAN IP address in my router is the same as shown on the canyouseeme.org.


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #10 on: August 11, 2009, 03:34:57 pm »
If it is working locally then it is working on the linkstations end.  I would contact your ISP and make sure the modem is bridged and that they don't block the port for some reason.. 
Message Edited by PCPiranha on 08-11-2009 03:35 PM

packdog

  • Calf
  • *
  • Posts: 16
Re: Cannot access LS-CHL from internet
« Reply #11 on: August 11, 2009, 06:33:34 pm »
   

hello guys,

 

I'm having the same problem: the linkstation works fine locally but i can't get it to see my modem's IP nor the linkstation from the internet.

 

In the last post you mentioned that the ISP may have blocked that port (9000). what then is preventing us from choosing a different port? or can the isp block incomming traffic specifically? 


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Cannot access LS-CHL from internet
« Reply #12 on: August 11, 2009, 07:03:22 pm »

Web access runs on port 9000.  The only thing you can do to change this is port to port forwarding, but 9000 will need to be properly forwarded.

 

Did you can you see me and check to see if you're double natting?


packdog

  • Calf
  • *
  • Posts: 16
Re: Cannot access LS-CHL from internet
« Reply #13 on: August 11, 2009, 07:49:10 pm »
   

I played with the canyouseeme.org and found:

 

port 9000 Success: I can see your service on XX.XX.XX.XXX on port (9000) Your ISP is not blocking port 9000

Port 9009: (the port i've set the nas to run through and the router to foward) Error: I could not see your service on xx.xx.xx.xxx on port (9009) Reason: Connection refused

9011 (firewalled port): Error: I could not see your service on xx.xx.xx.xxx on port (9011) Reason: Connection timed out 

 

The success does not suprise me, as buffalonas.com will consistantly provide the proper IP address so i know the connection is getting out. Notice the two error reasons: refused and timed out. there is definately a fowarding issue here, either router won't foward or my nas won't accept the connection. anyone?


packdog

  • Calf
  • *
  • Posts: 16
Re: Cannot access LS-CHL from internet
« Reply #14 on: August 11, 2009, 08:05:52 pm »
   

I also turned on my router's log

incomming:

source IP                    destination port

204.16.252.112                         9000

204.16.252.112                         9009

that's me on canyouseeme.org testing ports

Outgoing:

 Lan IP                 Destination URL/IP                Service/Port number

192.168.0.2              210.173.160.57                          123

192.168.0.2              192.168.15.255                          137

192.168.0.2              192.168.15.255                          138

 

The 210 IP is my NAS (192.168.0.2) gettin to the ntp server.

Why is my nas trying to contact a 192.168.15.255 on my network, and what the hell is it? i don't have anything explicitly set up to that address. What is my NAS doing trying to talk via 123, 137 and 138? soo many questions....

Message Edited by packdog on 08-11-2009 08:21 PM
Message Edited by packdog on 08-11-2009 09:01 PM