Author Topic: LS412DE useable at all?  (Read 570 times)

gale.david

  • Calf
  • *
  • Posts: 2
LS412DE useable at all?
« on: May 24, 2019, 12:14:41 am »
Hi,

I just got myself a used Buffalo LinkStation 421DE NAS. I'm convinced that hardware itself is functioning properly. However when it comes to software part - NAS navigator and WEB UI then everything I touch seems to be broken. For example.
  • I try to modify some setting from WEB UI. Then save it. I get popup that buffalo nas cannot be reached. After that when I navigate to WEB UI it is either blank or aborts to load with some JavaScript error. Restarting won't help but doing a manual reset will.
  • HDD formatting does not work. Just says can't format without providing any further explanation.
  • When I managed to format HDD externally and try to map drive in Windows 10 via NAS Navigator it says there is no share directory.
while in fact there is.

How do you guys even use this device? Everything I touch seems to be completely f-d up. I'm running 1.85 firmware. I've heard that earlier firmwares are less buggy. Which version would you recommend?


1000001101000

  • Debian Wizard
  • El Toro
  • ****
  • Posts: 388
  • There's no problem so bad you cannot make it worse
Re: LS412DE useable at all?
« Reply #2 on: May 24, 2019, 10:15:44 am »
I agree with @oxygen8, I'd say your first step would be to run diagnostics on the drives and make sure the issue isn't related to the drives having problems. Since it sounds like you've already formatted them i would take it a step further and completely wipe the drives and do a fresh firmware install to see if that helps.

The trouble with connecting to windows 10 could mean you need to enable SMBv2 on the device and/or in windows.  There are other posts in this forum that describe that in more detail. I think @oxygen8 has a german how-to on that too.

This device has an easy method for doing a full install from the built-in flash:
https://www.buffalotech.com/knowledge-base/Initial-Setup-of-LinkStation-421DE-or-441DE-Diskless-Enclosure

If you're truly dissatisfied with buffalo's firmware on this device you can always install Debian instead:
https://github.com/1000001101000/Debian_on_Buffalo

You can find all that information and more on the wiki page i created for this device:
https://buffalonas.miraheze.org/wiki/Linkstation_LS421D



gale.david

  • Calf
  • *
  • Posts: 2
Re: LS412DE useable at all?
« Reply #3 on: May 26, 2019, 12:54:06 am »
Thanks for the suggestions. I might try installing Debian one day.