Author Topic: LS-X1.0TL Flashing Blue Light of Death -- Looking for Circuit Board Replacement?  (Read 1178 times)


  • Calf
  • *
  • Posts: 2
Hi, all!

So my office has a Linkstation Live NAS model LS-X1.0TL, and I noticed that the drive started intermittently showing up on the network, until it could be barely accessed, and is no longer showing up at all. Tried re-configuring it on the network through all manner of different ways, and even seeing if it could be connected directly to a computer via Ethernet and be recognized with the NAS Navigator software (most recent version 2.96), also to no avail. Tried unplugging it (power) and plugging it back in, etc -- nothing. The router sometimes sees the device on the network and assigns it an IP address, but regardless it will not show up in NAS Navigator2. Noticed the constant blue flashing light on the front, even without the sound of HDD activity, and after doing some research (some people suggested a firmware flash, but there is no way I can get the NAS to be detected, so that's out), have come to the conclusion that the circuit board has failed.

I am confident the issue is with the circuit board and not the HDD, because I used UFS Explorer Professional Recovery 5.6 (64-bit) without even a hiccup to detect the partition, and am currently backing up the data from the drive.

So, I am currently looking around to find a circuit board replacement. Calling Buffalo Support, they said to try the forum, as some businesses collect and sell these and other parts for refurbishment. They did not carry the parts themselves to be issued as replacement, via payment or otherwise.

So if anyone could point me to the right direct as to where I could find a circuit board replacement, that would be great. I try to keep unnecessary costs down, around here, if I can fix things, myself.

Thanks to anyone who can help in any way,
-- Steve
« Last Edit: May 15, 2019, 03:13:55 pm by SteveC1982 »


  • The Oxy-genuine article
  • El Toro
  • ****
  • Posts: 380
  • Giving you some breathing space.
I am using Buffalo devices for 10 years.
Never i had a demaged board.

After your backup delete all partitions and try it in the nas.
A perfrect running board should give you E06, red blinking.

then read about E06
my german howto:

you should use an ups to prevent blue blinking


  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 829
  • There's no problem so bad you cannot make it worse
I believe @oxygen8 is correct, most likely the boot partition or partition table got corrupted/damaged.

Since you've already removed the disk you can create a new boot partition and load the firmware files to recover the device. That process is described in this guide:


  • Calf
  • *
  • Posts: 2
Hi guys,

Thank you both, that makes sense. I'll definitely give it a try and report back my results.