Author Topic: Terastation - System Error E04 – Can’t load Kernel  (Read 2475 times)


  • Calf
  • *
  • Posts: 1
Terastation - System Error E04 – Can’t load Kernel
« on: January 06, 2019, 03:51:31 am »
I purchased many years ago the Buffalo Terastation, model HS-DH1.0TGL/R5, and had last weeks an access problem after an electric power failure due to thunderstorms in our region.

I was able to ping the Terastation but no luck with accessing to the share or web interface.

I tried several shutdowns and got each time the message   "System Error E04 – Can’t load Krnel"   and the Terastation moved in the Emergency Mode. Pinging was possible but no other access.

I downloaded the latest available NASNavigator2.93, and it showed that the Terastation was in Emergency mode. The Terastation displayed the "EMDB3” code.

The notice on the Navigator was   "EM mode was detected. Update firmware or contact your local technical support".

I downloaded the latest TSUpdater and firmware (hs-dhtgl-up_214_102).

I ran the TSUpdater program and when it finally finished transferring, it returned the following error message :  HS-DHTGL-EMDB3 returns an error. (ACP_STATE_FAILURE). Updating is aborted."

On the Terastation the following error messages were displayed :
                HD3 Error E23     HD3 is faulty       with red light on HD3
and        OperationModeI12         Degrade Mode

I had no more access to the Terastation even no pinging was possible and I did a shutdown.

After rebooting, the message System Error E04 – Can’t load Krnel was again displayed - no errors at Harddisk level - and the Terastation moved in the Emergency Mode.

As indicated in the forums to launch again the TSUpdatern I tried but I got the following error message
Couldn’t confirm a response from HS-DHTGL-EMDB3
Please check a network addressof both PC and HS-DHTGL-EMDB3
Please disable the Firewall function if it is working on PC
Updating is aborted
The IP address displayed on the Terastation has not changed and it replies to the ping requests.

To conclude, I can no more launch the Update program and I am asking what should I do as next.
Any ideas ?
Thanks for your feedback


  • 1500 Lb Water Buffalo
  • Administrator
  • *****
  • Posts: 325
Re: Terastation - System Error E04 – Can’t load Kernel
« Reply #1 on: January 09, 2019, 05:32:21 pm »
Pull drive 3 out and see if it boots. If not, there isn't much else to do. If it does, back up your data immediately, if you don't have one.

--If that doesn't work--

If you need the data, I recommend contacting our Data Recovery team (US / Canada only). Local tech support can refer you to a recovery service in other regions.

If you just want the unit working, I don't mind telling you that I haven't the faintest idea how to recover the OS on that venerable old guy, or if there ever was a process.

It's dead, Jim. Time for a new one.
**A single copy of data, even on a RAID array, is NOT a backup! Hard drive failure is not a question of IF, but WHEN! Don't take my word for it, take Google's!**


  • Calf
  • *
  • Posts: 2
Re: Terastation - System Error E04 – Can’t load Kernel
« Reply #2 on: April 03, 2019, 01:25:46 pm »
For Future searchers...

First off I have only registered to post up something helpful for future generations :-P

Back story:
After a brief powercut/surge/whatever, my terastation Pro 2 HD-H2.0tgl/R5 took ages to boot...loading kernel... after about 5-7 minutes, it failed with System Error E04 - Can't load Kernel.

All round the houses:
I was scared to touch anything incase I lost my raid. So I took images of each disk and set about trying to reconstruct my raid outside of the NAS box.
It took me nearly 24 hours to image each disk (to a compressed file in R-Studio) 4x 2TB WD20EURS Green's.

Once I had the images, I felt I could play around a little while leaving R-studio to do it's thing.
RE: Raid recovery. I have given up but that's another story.

Summary & possible fix for others with E04 error:
Discounting all the time I spent messing around, I have summarised what I think brought my raid back online and allowed me to access the data.

Remove All 4 disks out of the terastation (image them to safe guard you).
Remove power
Press power button to drain the capacitors.
Put the power cable back in.
Open the drive door and press and hold the button under the LCD screen (looks like a fairly standard factory default button.
The NAS should boot into EM Mode.
Once it announces it has an IP of, Press and hold the power button for 8-10 seconds, until the unit powers off.
Remove power cable. and press the power button to drain excess power.
Add the disks back in (make sure they are in the same order).
Plug in the power cable and press the power button.
Sacrifice a live chicken.
What should happen is the NAS comes back up with RAID5 intact as if nothing had ever happened...You should feel an air of smugness from the NAS.

During my playing around I bought another HD-h2.0TGL/R5 with 4x 500GB disks in it. I took these 4 disks and variously tried them in my NAS (before and after the reset button). It is possible that the info on them was transferred to the NAS as part of the boot up. I cannot confirm/deny. all I know is it booted with Disk 1 in place but complained of the other disks being missing.
The power off, remove power cable etc may not be neccesary but I did it anyway.

Other useful info:
Here is a bunch of info that I found that might help future searchers sort out their specific problem:

The Raid5 is apparently a linux based RAID5.
Big Endians or something.
R-studio has problems detecting RAID5 parameters. It will find a config with 15.7% confidence if you do just the data partitions, but it won't then let you scan the virtual raid. you have to change one of the parameters in order to scan it, but then your data is er...not right. Restore large photo files to test.

I hope someone finds this drivel useful one day


  • Calf
  • *
  • Posts: 2
Re: Terastation - System Error E04 – Can’t load Kernel
« Reply #3 on: April 13, 2019, 03:40:29 pm »

So it seems the above wasn't entirely successful. I suspect the powercut/surge corrupted some part of the firmware. After a few restarts, I got the same E04 error..even after following my post above again, still couldn't bring it back.

After some more searching I found this post on reddit. I was aiming to factory reset the NAS, reformat and build from scratch.

A couple of notes for TS-H2.0TGL/R5 owners

As you follow the article through, you'll want to know exactly what to download...what worked for me, first time, was the following:

TFTP Boot TS-HTGL-R5 1.20.exe (bottom of the list)
Firmware for the "TS-HTGL: TS-HTGL/R5: TeraStation™ Pro II" - UK site.

Step 5
TeraStation Live(HS-DHTGL)
1.13   IeY8omJwGlGkIbJm2FH_MV4fLsXE8ieu0gNYwE6Ty

I have now tried every maifestation of shutting the box down, included just pulling the power. and it has come back up each time, with all shares and data still in tact (I took a copy of the data when it was up the first time (see previous post).

Hope this helps someone.