Author Topic: Can't Map Drive On Other NAS Unit  (Read 320 times)


  • Calf
  • *
  • Posts: 17
Can't Map Drive On Other NAS Unit
« on: November 16, 2020, 11:33:07 am »
I currently have a Buffalo LS441D (LS441DCF1) with firmware Version 1.85-0.01 and also an Asustor AS-604T.

I'm trying to set up a mapped drive on my Asustor NAS, with the mapped drive being a share on the Buffalo NAS unit. I've followed the instructions given in the following guide (for Asustor units):

and have done everything on the Asustor NAS side. However, it needs SSH enabled on the Buffalo NAS and for that I downloaded 'ACP Commander' which can be found here:

I've run it and it reports that SSH has been enabled.

This is how the NAS units are set up:

Buffalo NAS: with 'share' folder (top level)
Asustor NAS: with 'Buffalo' share folder

I then used PuTTY with root access on the Asustor to enter the command 'mount -t nfs /volume1/Buffalo' but it gives the following error messages, 'mount: RPC: Remote system error - Connection refused' as well as 'mount: mounting on /mnt failed: Bad file descriptor'

I then tried using PuTTY to access the Buffalo NAS but it gives me a 'Connection refused' message.

I've already asked questions about this on the Asustor forum but the issue seems to be at the Buffalo end, and I can't find anything meaningful in the Buffalo menus.

I've also searched through this forum and found a couple of posts about people doing this successfully (two Buffalo NAS units) using the same ACP Commander program.

Is there something I'm missing on the Buffalo NAS side preventing me getting access? The Buffalo NAS is set up with four disks in an array called 'Array1'. I've tried substituting that in place of the first '/volume1/' in the mount command above but still no joy.

It was suggested I try using CIFS instead of NFS but I don't understand these enough to venture down that route without a written guide.


  • Debian Wizard
  • Big Bull
  • *****
  • Posts: 915
  • There's no problem so bad you cannot make it worse
Re: Can't Map Drive On Other NAS Unit
« Reply #1 on: November 17, 2020, 11:09:12 am »

I updated acp_commander a while back to be more reliable and add some new features. Enabling telnet is more reliable across devices/versions than the various ssh methods (despite the drawbacks of telnet). That can be found here:

I believe this method for enabling ssh worked on ls400 devices (it's been a couple years since I tested that):