Author Topic: HD-PZ1.0U3S-ME .exe won't load  (Read 796 times)


  • Calf
  • *
  • Posts: 1
HD-PZ1.0U3S-ME .exe won't load
« on: December 06, 2018, 11:31:27 am »
Hi all,

I have the above drive (or at least I think that's the model, the number is very faded), and the .exe file will no longer load. I desperately need the files (they contain my PHD thesis), and would really love some help with this.

It was working just fine, until one day, I plugged it into a different machine to that which I normally use. It worked once, and then never worked again. Now every time I plug it in, it will load the drive, I'll be able to double click the .exe, but it won't load the password entering GUI.

I tried to go back to my old laptop, but I had dropped it and had to install to a New SSD and now that won't recognise it either. I have the password, but I really need a way to circumvent/fix this somehow.

I have several different machines running Windows 10. One is a DIY desktop, the other an HP laptop (the original machine).


P.s - I'd love to contact support, but I bought the drive in Dubai, and the serial number has faded, a lot. I can make out maybe 5/6 numbers.
« Last Edit: December 06, 2018, 11:33:29 am by Suchiththa »