Author Topic: Wifi disconnects for 2 seconds once every few minutes  (Read 926 times)

ubershmekel

  • Calf
  • *
  • Posts: 3
Wifi disconnects for 2 seconds once every few minutes
« on: November 14, 2018, 07:48:24 pm »
This is an unfortunate development. I thought my Buffalo wifi router [1] was invincible. It's been going strong with zero malfunctions for over 5 years now. I noticed a few weeks ago that when I video conference there can be a 2-3 second time out once every 1-3 minutes. I pinged 8.8.8.8 and my router seeing that both were timing out, but when I ssh to the router I see that pings to 8.8.8.8 from there don't fail. I thought it might be my computer or network card, I bought a different USB wifi interface and the issue still occurred. I tried to ping at the same time on my Windows machine and my Macbook, the Macbook seems to experience the same problem though to a lesser extent and not in sync with the Windows desktop. There's nothing interesting in /var/log/messages on the router. I'm pasting my current information here in case this helps someone to know they're not alone or if anyone has an idea what could be done. Right now my next step is to install a new firmware version on the dd-wrt and cross fingers.

Pinging from my mac to internet times out.
64 bytes from 8.8.8.8: icmp_seq=28710 ttl=122 time=11.722 ms
64 bytes from 8.8.8.8: icmp_seq=28711 ttl=122 time=13.892 ms
64 bytes from 8.8.8.8: icmp_seq=28712 ttl=122 time=14.995 ms
64 bytes from 8.8.8.8: icmp_seq=28713 ttl=122 time=11.061 ms
64 bytes from 8.8.8.8: icmp_seq=28714 ttl=122 time=11.829 ms
64 bytes from 8.8.8.8: icmp_seq=28715 ttl=122 time=14.864 ms
Request timeout for icmp_seq 28716
64 bytes from 8.8.8.8: icmp_seq=28717 ttl=122 time=14.254 ms
64 bytes from 8.8.8.8: icmp_seq=28718 ttl=122 time=11.530 ms
64 bytes from 8.8.8.8: icmp_seq=28719 ttl=122 time=28.367 ms

Pinging from my mac to the router doesn't always time out when the internet times out.
64 bytes from 192.168.11.1: icmp_seq=14854 ttl=64 time=1.865 ms
64 bytes from 192.168.11.1: icmp_seq=14855 ttl=64 time=1.079 ms
64 bytes from 192.168.11.1: icmp_seq=14856 ttl=64 time=0.967 ms
64 bytes from 192.168.11.1: icmp_seq=14857 ttl=64 time=1.086 ms
64 bytes from 192.168.11.1: icmp_seq=14858 ttl=64 time=1.478 ms
64 bytes from 192.168.11.1: icmp_seq=14859 ttl=64 time=1.069 ms
64 bytes from 192.168.11.1: icmp_seq=14860 ttl=64 time=1.193 ms
64 bytes from 192.168.11.1: icmp_seq=14861 ttl=64 time=1.332 ms
64 bytes from 192.168.11.1: icmp_seq=14862 ttl=64 time=1.201 ms
64 bytes from 192.168.11.1: icmp_seq=14863 ttl=64 time=1.073 ms

Pinging from my ssh into the router does not time out
64 bytes from 8.8.8.8: seq=283 ttl=123 time=10.313 ms
64 bytes from 8.8.8.8: seq=284 ttl=123 time=10.482 ms
64 bytes from 8.8.8.8: seq=285 ttl=123 time=31.953 ms
64 bytes from 8.8.8.8: seq=286 ttl=123 time=88.718 ms
64 bytes from 8.8.8.8: seq=287 ttl=123 time=9.423 ms
64 bytes from 8.8.8.8: seq=288 ttl=123 time=17.369 ms
64 bytes from 8.8.8.8: seq=289 ttl=123 time=9.687 ms
64 bytes from 8.8.8.8: seq=290 ttl=123 time=12.616 ms
64 bytes from 8.8.8.8: seq=291 ttl=123 time=12.882 ms
64 bytes from 8.8.8.8: seq=292 ttl=123 time=15.232 ms
64 bytes from 8.8.8.8: seq=293 ttl=123 time=10.286 ms
64 bytes from 8.8.8.8: seq=294 ttl=123 time=10.898 ms
64 bytes from 8.8.8.8: seq=295 ttl=123 time=9.367 ms

Pinging from my Windows machine sometimes times out in tandem and sometimes separately from the mac:
Reply from 8.8.8.8: bytes=32 time=34ms TTL=122
Reply from 8.8.8.8: bytes=32 time=11ms TTL=122
Reply from 8.8.8.8: bytes=32 time=11ms TTL=122
Reply from 8.8.8.8: bytes=32 time=35ms TTL=122
Reply from 8.8.8.8: bytes=32 time=12ms TTL=122
Reply from 8.8.8.8: bytes=32 time=11ms TTL=122
Reply from 8.8.8.8: bytes=32 time=13ms TTL=122
Reply from 8.8.8.8: bytes=32 time=26ms TTL=122
Reply from 8.8.8.8: bytes=32 time=15ms TTL=122
Reply from 8.8.8.8: bytes=32 time=17ms TTL=122
Reply from 8.8.8.8: bytes=32 time=53ms TTL=122
Reply from 8.8.8.8: bytes=32 time=29ms TTL=122
Reply from 8.8.8.8: bytes=32 time=14ms TTL=122
Request timed out.
Reply from 8.8.8.8: bytes=32 time=15ms TTL=122
Reply from 8.8.8.8: bytes=32 time=12ms TTL=122
Reply from 8.8.8.8: bytes=32 time=15ms TTL=122
Reply from 8.8.8.8: bytes=32 time=13ms TTL=122
Reply from 8.8.8.8: bytes=32 time=13ms TTL=122
Reply from 8.8.8.8: bytes=32 time=15ms TTL=122
Reply from 8.8.8.8: bytes=32 time=14ms TTL=122

The Windows machine almost always times out both 8.8.8.8 and my wifi router in tandem.
Reply from 192.168.11.1: bytes=32 time=2ms TTL=64
Reply from 192.168.11.1: bytes=32 time=3ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=9ms TTL=64
Reply from 192.168.11.1: bytes=32 time=5ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=21ms TTL=64
Reply from 192.168.11.1: bytes=32 time=2ms TTL=64
Reply from 192.168.11.1: bytes=32 time=2ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1776ms TTL=64
Reply from 192.168.11.1: bytes=32 time=5ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=3ms TTL=64
Reply from 192.168.11.1: bytes=32 time=1ms TTL=64
Reply from 192.168.11.1: bytes=32 time=2ms TTL=64
Reply from 192.168.11.1: bytes=32 time=3ms TTL=64

Cheers and thanks,

Yuval

[1] AirStation™ HighPower N600 Gigabit Dual Band Open Source DD-WRT Wireless Router - WZR-600DHP
Firmware: DD-WRT v24SP2-MULTI (11/04/12) std
(SVN revision 20180)


ubershmekel

  • Calf
  • *
  • Posts: 3
Re: Wifi disconnects for 2 seconds once every few minutes
« Reply #1 on: November 16, 2018, 02:14:45 pm »
So I updated to 1.91, which prompted me to update to 1.97. Now I was on WZR-600DHP Ver.1.97 (R1.04/B1.00) which was a terribly ugly interface compared to the original admin interface and I think the problem was still there.

I updated to DD-WRT v3.0-r30356 std (11/30/17) using the wzr600dhp-pro-v3.0-r30356.zip which brought back the pretty interface and I believe fixed the problem. Hoping it doesn't come back.

ubershmekel

  • Calf
  • *
  • Posts: 3
Re: Wifi disconnects for 2 seconds once every few minutes
« Reply #2 on: November 19, 2018, 01:54:26 am »
Scratch that. I think I still see the disconnects, they're just slightly less frequent though when they do occur they seem to be a bit longer (5 seconds instead of 3). I've ordered a different wifi router.