Author Topic: (Solved) Buffalo CloudStor CS-X1.0 can't be installed firmware  (Read 775 times)

vudaucua

  • Calf
  • *
  • Posts: 6
(Solved) Buffalo CloudStor CS-X1.0 can't be installed firmware
« on: October 13, 2018, 06:55:27 am »
Thank you very much 1000001101000 and oxygen8, you both rescued my NAS.



Hi friends, i have a NAS Buffalo CS-X1.0 with a new HDD.

I connected it to my PC, changed IP address of PC to 192.168.11.1.
I tried all TFTP Boot in this link https://drive.google.com/drive/u/0/folders/0B_oFnRRMAwk0SkYtdGpSdTNKTk0
but the LSupdater and BUFFALO NAS Navigator couldn't discover any device and the blue LED in NAS blinked continously.

Is there any one has correct TFTP Boot version for this model ?
Please help me, thank you very much.





PS: I also have another Buffalo NAS LS-CHL and installed firmware for it successfully.
« Last Edit: October 16, 2018, 03:56:11 am by vudaucua »

oxygen8

  • Buffalo
  • ***
  • Posts: 244
  • Giving you some breathing space.
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #1 on: October 13, 2018, 10:39:53 am »
download the actual firmware
now rename the file

initrd.img to initrd.buffalo

and

uImage.img to uImage.buffalo

this are your tftp files


Pogo is offline
I recommend you to modify the CS-X1.0-EU to LS-X1.0TL-EU



vudaucua

  • Calf
  • *
  • Posts: 6
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #2 on: October 13, 2018, 11:25:42 pm »
@oxygen8

Thank you

I have downloaded both firmwares for CS-X and LS-X
http://buffalo.jp/support_ap/support/products/cs_wv_x.html
https://www.buffalotech.com/products/linkstation-live-ls-x

And renamed file as you said. I have tried both TFTPd64 and TFTP Boot but the issue was the same.
The LSupdater and BUFFALO NAS Navigator couldn't discover any device and the blue LED in NAS blinked continously.

oxygen8

  • Buffalo
  • ***
  • Posts: 244
  • Giving you some breathing space.
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #3 on: October 14, 2018, 04:31:21 am »
Your bootloader must fit the tftp

which firmware was installed

you need the files from this old firmware

vudaucua

  • Calf
  • *
  • Posts: 6
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #4 on: October 14, 2018, 07:21:15 am »
@oxygen8

I got this device from my friend without old HDD so i don't know which version of original firmware is. He bought it online.
I formatted new HDD to XFS and EXT3 and tried again but still not successful.


Here is the information of device:




oxygen8

  • Buffalo
  • ***
  • Posts: 244
  • Giving you some breathing space.
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #5 on: October 14, 2018, 09:52:21 am »
You have to delete all aprtitions an the new drive

try it first with gpt



if this is not successfull, use mbr

vudaucua

  • Calf
  • *
  • Posts: 6
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #6 on: October 15, 2018, 03:12:01 am »
This model is very old, from 2011. I know that it only supports XFS HDD.
I have deleted all partition, rebuilt new mbr and created XFS partition.

I think the problem is not the HDD because i have another model from Buffalo. LSUpdater has option to format new HDD.

oxygen8

  • Buffalo
  • ***
  • Posts: 244
  • Giving you some breathing space.
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #7 on: October 15, 2018, 06:08:15 am »
"and created XFS partition."
this is wrong

Now LSupdater is not able to recreate the new partitions (5)

1000001101000

  • Debian Wizard
  • Tatanka
  • **
  • Posts: 51
  • There's no problem so bad you cannot make it worse
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #8 on: October 15, 2018, 09:55:50 am »
I think part of the problem is the use of the initrd.img and uImage.img in this manner. Those are password-protected zip files with contain the files your looking for, not the actual boot files.

I'm working on writing a proper guide for this process as it's somewhat confusing. In the meantime, to get the firmware to install on your device:

1. Get the boot files:
Download the firmware for your device, unzip it and find the *.img files containing the firmware

unzip initrd.buffalo, it contains initrd.buffalo
unzip uImage.buffalo, in this case it contains uImage-88f5182.buffalo. rename this to uImage.buffalo

the passwords are listed at https://vanducuy.wordpress.com/2010/08/09/buffalo-linkstation-revived/

2. Prepare the hard drive
create a partition table, mbr seems to work for all devices most newer ones also accept gpt
create partition1
format partition1 ext3
mount it and copy initrd.buffalo and uImage.buffalo to it

3. connect the drive to the device and boot it up, after a few minutes it should be in em mode.

4. Prepare LSupdater
edit LSpdater.ini and set no format = 0 and enable debug mode per: https://herzig-net.de/?page=unbrick_ls-wxl

5. Run LSupdater
It should find the device in EM mode.
go to the debug menu and check the boxes as described in (I typically just check them all if starting with a blank drive) :

https://herzig-net.de/?page=unbrick_ls-wxl

6. With any luck the firmware install will succeed and the device will boot up after about 10 minutes.

Like I said, I'm in the process of writing up a more detailed guide for this process but I think this should get you going. Let me know if it helps.



vudaucua

  • Calf
  • *
  • Posts: 6
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #9 on: October 15, 2018, 10:14:05 pm »
"and created XFS partition."
this is wrong

Now LSupdater is not able to recreate the new partitions (5)

I have deleted all partitions.
I tried in 4 cases, GPT and MBR with and without 1 partition. But was not lucky.




@1000001101000
Thank you, i am trying your guide.
« Last Edit: October 15, 2018, 10:15:59 pm by vudaucua »

oxygen8

  • Buffalo
  • ***
  • Posts: 244
  • Giving you some breathing space.
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #10 on: October 16, 2018, 12:30:31 am »
you have to use the extracted files
my info only renaming the files is wrong

vudaucua

  • Calf
  • *
  • Posts: 6
Re: Buffalo CloudStor CS-X1.0 can't be installed firmware
« Reply #11 on: October 16, 2018, 03:53:32 am »
Thank you very much 1000001101000 and oxygen8, you both rescued my NAS.

The point is i did't extract the uImage.img and initrd.img, 1000001101000's passwords worked like a charm.
In uImage.img archive, there are 2 files uImage-88f5182.buffalo and uImage-lsp.5.x.buffalo. My device worked with uImage-lsp.5.x.buffalo.

I didn't have to do anything with HDD, if we active debug mode in LSUPdate, it will rebuild partition table.

Here's the result


Thank you again.