Author Topic: "directory has vanished" errors when using rsync  (Read 174 times)

bptarpley

  • Calf
  • *
  • Posts: 1
"directory has vanished" errors when using rsync
« on: October 04, 2018, 01:28:22 pm »
We have a shared folder on our Terastation TS5810D with ~400GB of data (mostly small text files in git repos). The only File Sharing we have enabled on the appliance is NFS, and I'm sharing RW, Guest Permission Ignored, and Async. I mount this on our client by making an entry in /etc/fstab with the following options:

[NAS IP]:/mnt/array1/share/[folder]   /path/to/mount   nfs   rw,hard,rdirplus      0       0

The volume seems to mount correctly, and there are no errors on either the client or on the NAS. However, when attempting to rsync this mounted volume to a different location, things will work fine for ~3-4 minutes and then I receive errors that say "file has vanished" or "directory has vanished," preventing the vast majority of the files/directories from being transferred. This is not a busy filesystem. No one else is mounting this shared drive. No processes are deleting/updating files while rsync is doing its thing.

I've tried updating the firmware (now at latest). I've tried many other NFS options in /etc/fstab on the client. I've tried using "sync" instead of "async" on the NFS share options provided by the NAS web interface. Nothing helps. This prevents us from using the NAS for anything we need it for. Please help!