Author Topic: hd-h1.0tgl/r5 firmware  (Read 206 times)

LearningCurve

  • Calf
  • *
  • Posts: 6
hd-h1.0tgl/r5 firmware
« on: July 05, 2018, 12:04:15 am »
Hi,
I have recently bought the above and am pleased with it but have only had varied success using and setting it up.
I managed to change the ip address, restructured the raid which had 1 drive down, the drive was actually fine but had an error on it, and have reformatted the array, all with no problems at all.
However, it shows that it's firmware is version 1.20 and I believe that this is probably responsible for the following issues;
1/ I added a new user but although it says that it has saved the changes successfully, it does not save the password.
2/ There doesn't appear to be capability to assign the user to a group as per my linkstation.
3/ Although my imac can see it I get an error message saying that "the version of the server you are trying to connect to is not supported"
4/ My linux box can only connect to and access it using the admin user/password, presumably due to no.1
So, presumably these problems are due to the very old firmware I want to update it, but there are dozens of posts from people who have had problems with these updates and I cannot be sure of the correct firmware version to update to because;
1/ I have downloaded 112-104 from buffalo.com but I am in the UK so is it a universal english version?
2/ To try and verify the correct version for my ts i tried entering the serial number which, I guess because it is a uk box comes up as invalid.
3/ Trying the same on the uk site, it will not accept either the model number or the serial number.
Because of the problems some have had, I do not want to flash it until I am pretty sure I have the right fw.
Lastly is it possible to backup the installed fw to usb stick or whatever so that I could always fall back on it if need be?
In case anyone can check my specific ts for compatability the model number is hd-h1.0tgl/r5 and the serial number is 45802750812567.
Thanks for any help, Mike

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5870
Re: hd-h1.0tgl/r5 firmware
« Reply #1 on: July 05, 2018, 07:52:41 am »
PM me for TFTP / Boot Images / LSRecovery.exe file.

LearningCurve

  • Calf
  • *
  • Posts: 6
Re: hd-h1.0tgl/r5 firmware
« Reply #2 on: July 05, 2018, 09:24:38 am »
Thanks davo,
Much appreciated, am downloading it now and will flash it a bit later, maybe tonight.
Mike

LearningCurve

  • Calf
  • *
  • Posts: 6
Re: hd-h1.0tgl/r5 firmware
« Reply #3 on: July 05, 2018, 11:38:19 pm »
Hi,
Downloaded and flashed it last night and pretty much everything is ok.
The new user I added now has it's password saved but there doesn't seem to be anyway of adding it to hdusers group and so it cannot be used as a share user only to log into the interface, so it looks like I'll just have to use guest which doesn't have a password and can't be accessed through user management to assign one!  This seems like a pretty big security hole but there you go at least it's share access rights can be controlled.
so a very big thank you to davo for the link.

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5870
Re: hd-h1.0tgl/r5 firmware
« Reply #4 on: July 06, 2018, 06:31:21 am »
I haven't used this unit in years but from memory you would be able to assign the individual user permission via the Shared folder -> Folder options tab? There would be no reason to assign it to a group.
PM me for TFTP / Boot Images / LSRecovery.exe file.

LearningCurve

  • Calf
  • *
  • Posts: 6
Re: hd-h1.0tgl/r5 firmware
« Reply #5 on: July 06, 2018, 09:04:37 am »
Hi davo,
yes that is how it works on this one it is different in the ls that I have.
Thanks,
Mike