Author Topic: Buffalo LS421DE LinkStation Stopped sending e-mail  (Read 375 times)

slwelch33

  • Calf
  • *
  • Posts: 11
Buffalo LS421DE LinkStation Stopped sending e-mail
« on: May 11, 2018, 01:48:55 pm »
I have a Buffalo LS421DE LinkStation unit (1 of 3) that was fine until a couple of weeks ago.
It suddenly stopped sending e-mail status reports to me:
 I have my e-mail address entered into the "Recipient(s)" area correctly.
 I have the SMTP Server Address entered correctly (mail.twc.com)
 I have the SMTP Port entered correctly (587)
 I have the Authentication Type entered correctly (LOGIN (SMTP-AUTH)
 I also have the Password entered.
This LinkStation is set up identically as the other 2 LS421DEs as well as 3 LS441DEs.
I have the reports: HDD status report; Fan error; Disk error selected, but never get any reports
I navigate to the Email Notification Settings and click on "Send Test Email":
 It returns the status "Job completed: Send test email notification" but I never get any e-mail from it.
I have "rebooted" the LinkStation several times, shut it down and left it off for several days, restarted it, but nothing seems to work.
Is there any step/procedure you can recommend to get this unit sending the appropriate e-mails.
BTW, the Firmware Version is 1.84-0.01
Any help would be appreciated.
Thanks,
Steve
steve.welch@tx.rr.com
Steve Welch

Texturtle

  • Administrator
  • *****
  • Posts: 662
  • RAID is NOT a substitute for a good backup
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #1 on: May 11, 2018, 02:12:41 pm »
Check with your email provider to make sure they aren't filtering it as spam.

slwelch33

  • Calf
  • *
  • Posts: 11
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #2 on: May 11, 2018, 06:59:24 pm »
I have a total of 6 Buffalo LinkStations active in my home and ALL of them are set up to transmit e-mail reports every day.
This unit was working fine up until a couple of weeks ago.
My e-mail provider has never blocked any of these reports.
If they were to block anything, it would be placed into a "junk mail" folder for my inspection.
Steve Welch

oxygen8

  • Buffalo
  • ***
  • Posts: 219
  • Giving you some breathing space.
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #3 on: May 12, 2018, 01:56:47 am »
analyse /var/log/messages

success
Code: [Select]
Nov  5 20:52:08 QVL root[8638]: [Web] Email status was changed
Nov  5 20:52:16 QVL sSMTP[16717]: Unable to set portno="587"
Nov  5 20:52:16 QVL sSMTP[16717]: Unable to set AuthType="TLS"
Nov  5 20:52:17 QVL sSMTP[16717]: Creating SSL connection to host
Nov  5 20:52:18 QVL sSMTP[16717]: SSL connection using DHE-RSA-AES256-SHA
Nov  5 20:52:19 QVL sSMTP[16717]: Sent mail for XXXXXXXXXXXXX@gmx.de (221 gmx.com Service closing transmission channel)

fail
Code: [Select]
Nov  5 20:50:42 QVL root[8638]: [Web] Email status was changed
...
Nov  5 20:50:49 QVL sSMTP[15035]: Authorization failed (535 Authentication credentials invalid)



try to download the files with CTRL + ALTGR + SHIFT + B

or open ssh
http://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/ssh-freischalten-auf-einer-ls421de-t2165.html

slwelch33

  • Calf
  • *
  • Posts: 11
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #4 on: May 28, 2018, 04:23:32 am »
I know that the response from oxygen8 was meant well, however, since I speak NO German, it was of little use to me.
I tried swapping out the troublesome LS421DE unit with another (slightly older) unit and with the same settings as the original one, got the same results - While the unit indicated that the test e-mail was successful, NO e-mail was ever received.
I tried changing the IP address of the unit and got the test e-mail, so I restored the original LS421DE with the original settings - Same results, NO e-mail received - Changed IP address down by 1 (xxx.xxx.x.31 to xxx.xxx.x.30) and Got the e-mail!
Sitting on my system for one day, the scheduled e-mail reports ALL came through fine!

I will be re-booting ALL of my LS421DE units (3 each) and All of my LS441DE units (3 each) just to keep them all in sync for future reference.

One final note: While I have had decent results using the Buffalo LS units, my latest unit, a NetGear ReadyNAS 214 with 4 6TB HDD units will ultimately replace the Buffalo units.
Steve Welch

oxygen8

  • Buffalo
  • ***
  • Posts: 219
  • Giving you some breathing space.
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #5 on: May 28, 2018, 10:18:05 am »
1. Why you do not use DHCP?

2. Why you do not post parts of your log?

3. Can you save your Log with  CTRL + ALTGR + SHIFT + B

slwelch33

  • Calf
  • *
  • Posts: 11
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #6 on: May 28, 2018, 07:05:40 pm »
1. I don't use DHCP because I have always been in the habit of assigning fixed IP addresses to machines in my Home network.
2. I have set up and used acp_commander but I have to install the JavaSetup (I do NOT keep Java installed on my machines, ever)
3. I don't understand your reference to CTRL+ALTGR+SHIFT+B ?????
I would not be able to get into SSH because I am in the process of converting ALL the LS421DE units to RAID1 and don't want to take any chance of messing anything up until the drives finish sync-ing BUF1 has 4TB drives so it will take a couple of days.
Steve Welch

oxygen8

  • Buffalo
  • ***
  • Posts: 219
  • Giving you some breathing space.
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #7 on: May 28, 2018, 08:16:44 pm »
open the admin webinterface of your nas with a browser
then

Press the key CTRL and hold it
Press the key ALTGR and hold it
Press the key SHIFT and hold it
Press the key B short

now you can download the package of logfiles

you do not need ssh


Quote
1. I don't use DHCP because I have always been in the habit of assigning fixed IP addresses to machines in my Home network.



This is a pity.
You have so many disadvantages.

A good router always assigns the same IP via DHCP.

I do not use IPs.

I use names, like
QVL
QVL2
LS520
...

slwelch33

  • Calf
  • *
  • Posts: 11
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #8 on: May 30, 2018, 01:58:56 pm »
Looking through my files I found that I had previously enabled SSH on the LS421DE units.
Here is the currently (working) results for my BUF1-NAS Mail (Using SSH):
[root@BUF1-NAS /]# cat /var/log/messages | grep sSMTP
May 30 00:00:02 BUF1-NAS mail.info sSMTP[13204]: Unable to set portno="587"
May 30 00:00:02 BUF1-NAS mail.info sSMTP[13204]: Unable to set pop3_server="mail.twc.com"
May 30 00:00:02 BUF1-NAS mail.info sSMTP[13204]: Unable to set pop3_portno="110"
May 30 00:00:02 BUF1-NAS mail.info sSMTP[13204]: Unable to set AuthType=""
May 30 00:00:06 BUF1-NAS mail.info sSMTP[13204]: Sent mail for steve.welch@tx.rr.com (221 2.0.0 dnvrco-cmomta02 cmsmtp closing connection) uid=0 username=root outbytes=848

So, I no longer have issues with the Mail portion of the LS421DE units.
BTW, I do not have webinterface enabled on any of my Buffalo units and I still, for the life of me, do not understand your key sequence - It looks like it requires a total of 6 fingers at the same time!!
I am fairly familiar with Linux (Fedora 28 and CentOS 7.5)
Steve Welch


slwelch33

  • Calf
  • *
  • Posts: 11
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #10 on: May 30, 2018, 06:54:41 pm »
You have got me really curious now - what kind of keyboard are you referring to?
I use a US/English keyboard and there is no ALTGR key to be found!
Steve Welch

oxygen8

  • Buffalo
  • ***
  • Posts: 219
  • Giving you some breathing space.
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #11 on: May 31, 2018, 12:02:39 am »
i use a german keyboards

try the ALT on the right side of Space
« Last Edit: May 31, 2018, 12:05:03 am by oxygen8 »

Texturtle

  • Administrator
  • *****
  • Posts: 662
  • RAID is NOT a substitute for a good backup
Re: Buffalo LS421DE LinkStation Stopped sending e-mail
« Reply #12 on: May 31, 2018, 09:14:42 am »
The key combination should be CTRL-ALT-Shift-B.