Author Topic: How to enable SMBv2 on Linkstation LS-WXL systems so it works with modern OSes  (Read 4821 times)

mishikal

  • Calf
  • *
  • Posts: 3
This requires enabling remote SSH access to the system, but once you do that and log in as root, modify /etc/init.d/smb.sh

There is a configure() function that calls /usr/local/sbin/nas_configgen -c samba, which always overwrites /etc/samba/smb.conf.  To allow SMBv2, modify the code as follows.

From:
Code: [Select]
        /usr/local/sbin/nas_configgen -c samba
        if [ $? -ne 0 ]; then
                echo "$0 configure fail"
                exit 1
        fi

To:
Code: [Select]
    /usr/local/sbin/nas_configgen -c samba
        if [ $? -ne 0 ]; then
                echo "$0 configure fail"
                exit 1
        fi
        /bin/sed -i '3i\\
    max protocol = SMB2\\
        ' /etc/samba/smb.conf


Then run /etc/init.d/smb.sh reload and the NAS will now allow SMBv2 connections.  Enjoy!
« Last Edit: August 08, 2017, 11:35:20 am by mishikal »

ArronHad

  • Calf
  • *
  • Posts: 1
Nice one Mishikal, it took me a couple of tries but got it working perfect in the end! Feels good to be all setup.

StephenDavis1977

  • Calf
  • *
  • Posts: 2
How do I do this on a Windows 10 machine that cannot access the LinkStation?

patator

  • Calf
  • *
  • Posts: 1
Quote
How do I do this on a Windows 10 machine that cannot access the LinkStation?

First you need to get root access on your linkstation using ACP Commander.
I used this http://nerdkey.co.uk/guides/enable-ssh-linkstation-stock-firmware/ as it sounded easy enough at that time.

For the next steps, I take it you are not familiar with Unix, so here is a step by step once you have root access.

Login as root using PUTTY
once done, type
cp  /etc/init.d/smb.sh /root
This will cpy the file in case you make a mistake.

vi  /etc/init.d/smb.sh
this editor is quite unfriendly, so follow the following key strokes ([ESC] is the key esape, not the letters):
[ESC]/nas_config
use the arrow to go at the end of this section:
Code: [Select]
/usr/local/sbin/nas_configgen -c samba
        if [ $? -ne 0 ]; then
                echo "$0 configure fail"
                exit 1
        fi
type A then enter
copy the following and right click to paste in putty:
Code: [Select]
/bin/sed -i '3i\\    max protocol = SMB2\\' /etc/samba/smb.confthen hit the following keys:
[ESC]:wq

to try that it worked:
/etc/init.d/smb.sh restart

You should now be able to access your files on Windows10.

Good luck!

« Last Edit: February 18, 2018, 11:33:20 am by patator »

jurrabi

  • Calf
  • *
  • Posts: 2
This might be a stupid question but, how come this is not enabled by default in the latest 1.74 firmware version for my Linkstation LS-WXL?? I mean, that update is dated Feb, 2018 and the Buffalo site states that the model is Windows 10 compatible witch can't be without SMBv2 enabled...
WTF?

Since I don't seem able to get root or SSH access to my device... what are my options?

Any ideas? thanks in advance.

oxygen8

  • Buffalo
  • ***
  • Posts: 107
  • Giving you some breathing space.
"Windows 10 compatible witch can't be without SMBv2 enabled.."

this is not correct
Microsoft have disabled SMB1

Now Windows is not compatibel to old nas

enable SMB1 on windows