Author Topic: OS X & LS210D - Error involving "TheVolumeSettingsFolder"  (Read 307 times)

Rob Hartzell

  • Calf
  • *
  • Posts: 2
OS X & LS210D - Error involving "TheVolumeSettingsFolder"
« on: April 01, 2018, 08:38:34 pm »
I just got LinkStation 210 (4TB), and for the most part, it seems to be working out pretty well (on a Mac mini running High Sierra). One thing that's happening, though: when I try to drag over my music folders (about 750-800 GB total) as a complete batch, they start copying -- but then the process comes to a halt with a message that "TheVolumeSettingsFolder" can't be copied because the name's too long or has illegal characters.

Other people, posting about other issues entirely, have posted the contents of their smb.conf file, which contains the lines:

Quote
veto files = /.AppleDesktop/Network Trash Folder/TheVolumeSettingsFolder/.AppleDouble/.AppleDB/
delete veto files = yes

I don't know if that's relevant to the problem, though -- I'm copying from (older, smaller) external hard drives to a "Music" folder on "shared", and I'm dragging and dropping the folders from those drives (rather than doing an option-drag copy of each drive). Dropping into Terminal, "ls -la" doesn't even turn up a directory called ".AppleDesktop" at the root level of any drive: not the boot drive, not the server drive, and not the drives I'm copying from.

Sometimes, I have to copy things over in smaller batches, and that seems to work just fine. Other times, I've had to copy things a folder or two at a time, just to get around the error. Again: once the batch is small enough, the error stops happening, so I'm kinda (no pun intended) buffaloed at this point.

Rob Hartzell

  • Calf
  • *
  • Posts: 2
Re: OS X & LS210D - Error involving "TheVolumeSettingsFolder"
« Reply #1 on: April 08, 2018, 01:13:27 pm »
Okay, found the problem. Some of the folders I was moving were from the data partition of enhanced CDs. Those folders had various invisible OSX desktop files and directories (though "TheVolumeSettingsFolder" only appeared in one of them). The solution: dropping into Terminal to remove them via command line.