Author Topic: DriveStation powering on, spinning, but not being recognized  (Read 347 times)

mrtastycakes

  • Calf
  • *
  • Posts: 3
DriveStation powering on, spinning, but not being recognized
« on: November 12, 2017, 01:09:14 pm »
Hey all,

This is a question for a DriveStation™ DDR - HD-GD3.0U3. I've been having this problem for quite awhile, but now it's rendered the drive basically unusable. So, when I plug in the USB, either to the drive or the PC, the drive will begin spinning like it's ready to go, and the little USB icon will even show up on the computer for a second, but then it will cease spinning and give no indication that it's on, remaining unrecognized by my PC. It's my PC for sure, as I've tried it with a few. On a couple of occasions, it has randomly started working, and all the files are fine, so I don't think it's corrupted in any way either.

Anyone have a similar problem and know of a solution? The male end of the USB cable that connects to the drive is a little bent, but I'm not sure that that's it.

Thanks, I have a lot of stuff on the drive I need!

Texturtle

  • Administrator
  • *****
  • Posts: 676
  • RAID is NOT a substitute for a good backup
Re: DriveStation powering on, spinning, but not being recognized
« Reply #1 on: November 13, 2017, 10:30:44 am »
I'm not sure I understand, do you mean it exhibits the same behavior on multiple computers? It sounds like it could be a connection problem, have you tried a different cable?

mrtastycakes

  • Calf
  • *
  • Posts: 3
Re: DriveStation powering on, spinning, but not being recognized
« Reply #2 on: November 14, 2017, 09:06:48 pm »
Yes, same behavior on every computer. Haven't tried a different cable yet.

mrtastycakes

  • Calf
  • *
  • Posts: 3
Re: DriveStation powering on, spinning, but not being recognized
« Reply #3 on: November 28, 2017, 01:22:08 am »
Just got a brand new USB cable. Still doing the same thing. What the heck!

Texturtle

  • Administrator
  • *****
  • Posts: 676
  • RAID is NOT a substitute for a good backup
Re: DriveStation powering on, spinning, but not being recognized
« Reply #4 on: November 28, 2017, 11:14:26 am »
I'm not sure at this point. If you can hear the drive spinning it's likely that the drive itself is OK. It's unusual for the logic board in the enclosure to fail, but not impossible. It sounds like that may be the issue here.

If the unit is still under warranty you should be able to get it replaced by contacting tech support, but that doesn't help you with the data. If you open the enclosure yourself and attempt to recover the data from the drive it will likely void the warranty, especially if the enclosure is damaged as a result.

Drive Savers does give a discount to Buffalo customers for data recovery and will give you a free quote if you send them the drive. They would certify that they opened it and would not affect the warranty status of the drive.

It really comes down to two things: Is the drive still under warranty? If not, then you might be able to open the enclosure yourself and just the connect the bare drive to a desktop computer and retrieve the data. If it is under warranty then it comes down to whether it would be cheaper to go ahead and attempt to recover the data yourself and just buy a new external drive OR pay Drive Savers to recover the data and get this one replaced under warranty.