Author Topic: LS 421DE died swapping drives  (Read 151 times)

kal326

  • Calf
  • *
  • Posts: 2
LS 421DE died swapping drives
« on: September 08, 2017, 03:41:26 pm »
So shame on me for not noting that pulling drives and replacing them might kill a NAS.  I pulled two of three WD Red NAS 3TB drives from a machine without removing the original partitions or removing them from RAID 5.  So the RAID 5 volume still showed on the drives.

I left them in the NAS after startup for hours while running an errand thinking it would eventually boot normally as after 10-15 minutes nothing was coming up on the mobile or desktop NAS Navigator 2 or mobile app.

Doing some digging I found the issue with the red light blinking 7 times.  I have followed all of those steps including trying to TFTP boot and several items related to EM and flashing from the LSUpdater.  It never finds the NAS.  I also can not see the device ever making a DHCP request either or getting an IP.

On occasions I can ping the device on 192.168.11.150 when it's in EM or whatever mode.  I have gotten it to pickup boot images from https://www.aaronhastings.me/completely-recovering-from-a-bricked-buffalo-linkstation-ls200-series-nas-and-opening-the-firmware-too/ as it was my understanding that these were similar enough models, just one came with drives.

I have remove the Intel RAID 5 array from all three drives and also cleaned them in diskpart.  No partitions exist on any of the drives.

However I still have the following issue.  With or without a drive the NAS will power on and the top light will blink steadily white for a while before going to the only the bottom light blinking 7 times in red repeatedly.

If I quickly press the function button on the front while the red light is blinking 7 times the top light goes back to rapidly flashing white.  It is during this time I have had some success with pinging or getting TFTP to at least load something  Though again, conflicting posts about if this device supports TFTP or not even. So after the pushing of the function button it goes back to the quick flashing white top light only.  No light ever goes solid and the top light will flash for well beyond 10 minutes with no other activity.

During this time the LAN light will also flash like it has activity.  However, again no activity follows like the lights going solid. 

One other interesting thing I notice.  If you turn the switch on the back off, which should turn the device off.  The top light continues to blink white and LAN activity also continues.

Anybody go any other ideas for trying to get this back to working?  The original drives that were in the NAS were reformatted before I realized there was an issue or they were otherwise needed.  The device is years old and has worked perfectly until I tried going from 2TB drives to 3TB drives.

Texturtle

  • Administrator
  • *****
  • Posts: 535
  • RAID is NOT a substitute for a good backup
Re: LS 421DE died swapping drives
« Reply #1 on: September 08, 2017, 03:52:40 pm »
Since the 421DE originally shipped as a diskless enclosure you should be able to follow the standard setup for the device:

http://www.buffalotech.com/knowledge-base/Initial-Setup-of-LinkStation-421DE-or-441DE-Diskless-Enclosure

FYI, the power switch is actually a "soft" switch. Turning it off sends a shutdown command to the system.

kal326

  • Calf
  • *
  • Posts: 2
Re: LS 421DE died swapping drives
« Reply #2 on: September 08, 2017, 04:05:18 pm »
I have followed that guide, at about 55-60 seconds the power light stops fast blinking white and the function light starts the red 7 blink code which according to this means a hardware error.
http://en.faq.buffalo-global.com/app/answers/detail/a_id/14328/p/31,33

If I do not press the function button while the red light is blinking the soft switch does appear to shut the device down.  If I turn it back to on I hear the solo drive in the enclosure spin back up again like it did the first time I plugged the power back in and turned the switch on.

Again, this thing worked for 2-2.5 years just fine.  I literally just powered it down and swapped from Seagate 2TB drives to WD Red 3TB which are actually on the supported drives list while the Seagate one's were not.

Did something go back in the hardware with the drives swapping. Would having partitions or the weird raid configuration on the Red drives on first reboot have caused an issue.  At this point I could try to put one of the original drives back in and see if that works even though they have been formatted.  The WD Red drives work fine.  I have put them in a computer to ensure the RAID volume was remove and all partitions removed as well.  The format and clean in diskpart just fine.  I also hit them with the Quick Erase of the WD drive utility for good measure.

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5676
Re: LS 421DE died swapping drives
« Reply #3 on: September 08, 2017, 05:54:26 pm »
You need the recovery image for the unit.
PM me for TFTP / Boot Images / LSRecovery.exe file.