Author Topic: How to enable SMBv2 on Linkstation LS-WXL systems so it works with modern OSes  (Read 12993 times)

siamak

  • Calf
  • *
  • Posts: 1
Hi guys,

I have the same problem with my LS-CHL. I tried this solution. I activated the SSH as mentioned but when I try to access my device using Putty, and after entering my password the connection would be interrupted and I get this error from Putty: "Server unexpectedly closed network connection".

Do you guys have any suggestion for that? I mean it shouldn't be related to my device model. Does it?

Appreciate your help.

Bests
Siamak

gilcor55

  • Calf
  • *
  • Posts: 1
Hi Mischikal
Thanks for your contribution: it's precise and very well explained.
Since many years, I have a Buffalo ls-gl LinkStation and it worked very well til Windows 10 fall creator update.
It is a pain to use FTP transfer instead of windows explorer and after many search, I found your post on this forum.
I did all the steps you described, but at the end, when I restart the LinkStation, my windows 10 workstation still cannot connect with SMB2.
Do you know if there is a another way to force the ls-gl to use SMB2 ?
When I check the /etc/samba/smb.conf generated file, I find max protocol = SMB2 on the third line. How to know if it's "understood" from samba server?

Thanks in advance for answering me.