Author Topic: Enable SMB v2 for LS-WXL linkstations  (Read 10683 times)

mishikal

  • Calf
  • *
  • Posts: 5
Enable SMB v2 for LS-WXL linkstations
« on: August 08, 2017, 11:28:22 am »
Given the serious security issues in SMBv1, and the fact that LS-WXL linkstations ship with Samba 3.6.x, which has full support for SMBv2, the /usr/local/bin/nas_configgen binary needs to be updated to allow SMBv2, by adding the following line to the global section:

max protocol = SMB2

This will allow both SMBv2 and SMBv1 clients to work with the NAS.  Thanks.

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #1 on: August 21, 2017, 07:49:42 am »
I'm also waiting this feature.

Meantime for use my linkstation now i have modified /etc/init.d/smb.sh
after this line -->  /usr/local/sbin/nas_configgen -c samba
add this line -->  sed -i '2 i\    max protocol = SMB2' /etc/samba/smb.conf

after restart linkstation, my window pc with SMBv1 disabled, can work with the NAS.

best regards.

fabrizio.balboni

  • Calf
  • *
  • Posts: 2
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #2 on: May 21, 2018, 09:22:45 am »
i have a Linkstation LS-WXL/R1 and it doesn't work after the last update of WIN 10. I have installed e new firmware 1.74 but when i tried to access to the linkstation from the file Explorer the system send a message that protocol SMB1 is no longer supported. I have tried modify the /usr/local/bin/nas_configgen but it does not exists on my linkstation. Can you help me? thanks

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #3 on: May 22, 2018, 01:20:28 am »
i have modified  /etc/init.d/smb.sh  no /usr/local/bin/nas_configgen

best regards

fabrizio.balboni

  • Calf
  • *
  • Posts: 2
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #4 on: May 22, 2018, 02:04:23 am »
also /etc/init.d/smb.sh does not exists in my firmware

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #5 on: May 22, 2018, 02:08:34 am »
i have firmware 1.73.
best regards

FireHose

  • Calf
  • *
  • Posts: 1
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #6 on: June 29, 2018, 03:00:41 pm »
i have a Linkstation LS-WXL/R1 and it doesn't work after the last update of WIN 10. I have installed e new firmware 1.74 but when i tried to access to the linkstation from the file Explorer the system send a message that protocol SMB1 is no longer supported. I have tried modify the /usr/local/bin/nas_configgen but it does not exists on my linkstation. Can you help me? thanks

Please try installing 'SMB 1.0 Client/CIFS Client' from 'SMB 1.0 /CIFS File Sharing Support' on Windows 10 machines through Turn Windows Features ON/Off method. This should work.

Pendaws

  • Calf
  • *
  • Posts: 14
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #7 on: June 30, 2018, 04:22:06 am »
There is another way to get it to work with Windows, try these settings......
HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\ SMB1 -Type DWORD -Value 1

HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\ SMB2 -Type DWORD -Value 1

This requires a change to the registry, if you are not confident to work in this file, get someone who knows what to do and back up the registry before trying.
MS has made the SMB1 protocol null and void. Make sure that the two listings in Windows Features are turned on:

Check that network discovery is still ticked.
You will also need to make sure some settings in Services.msc are enabled and set to Auto:
* Network Connected Devices Auto-Setup
* Network Connections
* Network List Service
* Network Location Awareness
* Peer Networking Grouping
* Remote Procedure Call (RPC)
* Server
* SSDP Discovery
* TCP/IP Netbios helper
* UPnP Device Host
* WinHTTP Web Proxy Auto-Discovery Service
* Workstation.

The important thing is, before you try any changes, BACK UP YOUR SYSTEM.