Product Feature Requests > Feature Requests for TeraStation or LinkStation

Enable SMB v2 for LS-WXL linkstations

(1/2) > >>

mishikal:
Given the serious security issues in SMBv1, and the fact that LS-WXL linkstations ship with Samba 3.6.x, which has full support for SMBv2, the /usr/local/bin/nas_configgen binary needs to be updated to allow SMBv2, by adding the following line to the global section:

max protocol = SMB2

This will allow both SMBv2 and SMBv1 clients to work with the NAS.  Thanks.

luigi.sorato@creditotrevi:
I'm also waiting this feature.

Meantime for use my linkstation now i have modified /etc/init.d/smb.sh
after this line -->  /usr/local/sbin/nas_configgen -c samba
add this line -->  sed -i '2 i\    max protocol = SMB2' /etc/samba/smb.conf

after restart linkstation, my window pc with SMBv1 disabled, can work with the NAS.

best regards.

fabrizio.balboni:
i have a Linkstation LS-WXL/R1 and it doesn't work after the last update of WIN 10. I have installed e new firmware 1.74 but when i tried to access to the linkstation from the file Explorer the system send a message that protocol SMB1 is no longer supported. I have tried modify the /usr/local/bin/nas_configgen but it does not exists on my linkstation. Can you help me? thanks

luigi.sorato@creditotrevi:
i have modified  /etc/init.d/smb.sh  no /usr/local/bin/nas_configgen

best regards

fabrizio.balboni:
also /etc/init.d/smb.sh does not exists in my firmware

Navigation

[0] Message Index

[#] Next page

Go to full version