Author Topic: Enable SMB v2 for LS-WXL linkstations  (Read 7376 times)

mishikal

  • Calf
  • *
  • Posts: 5
Enable SMB v2 for LS-WXL linkstations
« on: August 08, 2017, 11:28:22 am »
Given the serious security issues in SMBv1, and the fact that LS-WXL linkstations ship with Samba 3.6.x, which has full support for SMBv2, the /usr/local/bin/nas_configgen binary needs to be updated to allow SMBv2, by adding the following line to the global section:

max protocol = SMB2

This will allow both SMBv2 and SMBv1 clients to work with the NAS.  Thanks.

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #1 on: August 21, 2017, 07:49:42 am »
I'm also waiting this feature.

Meantime for use my linkstation now i have modified /etc/init.d/smb.sh
after this line -->  /usr/local/sbin/nas_configgen -c samba
add this line -->  sed -i '2 i\    max protocol = SMB2' /etc/samba/smb.conf

after restart linkstation, my window pc with SMBv1 disabled, can work with the NAS.

best regards.

fabrizio.balboni

  • Calf
  • *
  • Posts: 2
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #2 on: May 21, 2018, 09:22:45 am »
i have a Linkstation LS-WXL/R1 and it doesn't work after the last update of WIN 10. I have installed e new firmware 1.74 but when i tried to access to the linkstation from the file Explorer the system send a message that protocol SMB1 is no longer supported. I have tried modify the /usr/local/bin/nas_configgen but it does not exists on my linkstation. Can you help me? thanks

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #3 on: May 22, 2018, 01:20:28 am »
i have modified  /etc/init.d/smb.sh  no /usr/local/bin/nas_configgen

best regards

fabrizio.balboni

  • Calf
  • *
  • Posts: 2
Re: Enable SMB v2 for LS-WXL linkstations
« Reply #4 on: May 22, 2018, 02:04:23 am »
also /etc/init.d/smb.sh does not exists in my firmware

Re: Enable SMB v2 for LS-WXL linkstations
« Reply #5 on: May 22, 2018, 02:08:34 am »
i have firmware 1.73.
best regards