Author Topic: Can not see Link Station LS-WXL on my network  (Read 9129 times)


  • Calf
  • *
  • Posts: 6
Can not see Link Station LS-WXL on my network
« on: July 12, 2017, 07:03:20 am »
I've set up a reconditioned Link Station on my network, connected via cat5 ethernet, direct to the router.

Heres what I did:
  • Switched it on by the mains
  • held down the function button
  • let go of the function button
  • held down the function button for another 5 seconds
The blue Power button continues to flash.

Here's what I know about the item:
The ip address was different and it was connected the to a domain
the domain had an unusual subnet

On occasions, the blue light stops flashing and goes off all together and the INFO/Error light flashes in batches of 6 flashes.

I'm connected via wifi to my router, the router that the link station is connected to, via wire.
I'm using OS X 10.15.5 and software NAS Navigator2 (nasnavi 291).
I can't tell what the firmware is because each time I run the software  (LS-series-fw173-fwmac.dmg) it can't find the link station on the network so suggests that the link station doesn't require the upgrade.

I've also run arp -a through terminal (cmd to PC users) and the only address I get back are my own and the routers, with no sign of the link station, so can't even see what the ip address is to ping it.

Here's a new one! I've even set the switch on the back to "off" and it is still running, 10 minutes gone and continuing to flash the blue light!

Can any one help, even to get the blue light steady and possibly enable me to at least see the device on the network?

##### UPDATE #####

I've completely over hauled the home network to replicate the domain the network the link station came from.

The LS still doesn't appear on any IP scans listed

Everything refers to accessing the LS using its IP address, but in this case it isn't possible.

The LS is currently set to the "OFF" condition, using the switch on the back, but its connected to the power source.

When the LS is set to the "ON" condition, using the switch on the back, the blue light continues to flash.

When the LS is switch to "OFF" using the switch on the back, it doesn't shut down.

I'm sure this LS can be restored to factory setting, but in this case it is not possible to over the network. Is there any other way to restore the device to factory settings? .....anyone?
« Last Edit: July 12, 2017, 01:11:28 pm by cwj73 »


  • Calf
  • *
  • Posts: 6
Re: Can not see Link Station LS-WXL on my network
« Reply #1 on: July 17, 2017, 06:28:23 am »
So, as you can see from above, the NAS was bricked pretty bad, but I fixed it... no thanks to Buffalo!

There was nothing on these disk, so i wasn't worried about losing data.

Here's how;

You will need;

Windows PC
2x Cat5 RJ45 standard (good quality) network ethernet cable
Router/Switch that you can config the LAN

NAS Navigator
Firmware Update Package.

Configure your router/switch to - disable DHCP - subnet - no gateway - turn off the extras routers wifi if it has it so, your pc doesn't get confused (need for later).

Turn off the the NAS and totally wipe the drives.  You can use disk manager or disk Util, but clean them.

Change your PC IP address to (regardless of what it was before)

Connect the PC to the NAS using the network cable.

Run TFTP software

Switch on the NAS using the switch at the back and hold down the function button for 10 seconds while it boots up (important to know where this switch and what it does).

After you let go, the blue, flashing light will stop and a red light will flash.

Hit the function button again so the blue flashing light starts up again.

Check your PC and the TFTP print out. It should, after a few minutes, start to print our a response. [if no response, run through the process again]

Don't try and ping, it won't respond.

Run NAS Navigator and wait for the device to appear.

When it appears, change the IP to something like;

It'll tell you it hasn't responded, but ignore the message and wait for the LS to stop groaning.

Unplug the network cable and from you PC and plug it directly into the router/switch, then get the other cat5 and and connect the NAS to the router with it.

Quit NAS Navigator and re run it. It should pick up the LS device and show it in the window.

No open the Update firmware, but don't run it, because if you've wiped the drives, you won't have any firmware installed to update.

Find the config file: LSUpdater.ini, right click and choose edit and make these changes to the last few lines, including adding special flags;

VersionCheck = 0
NoFormatting = 1


Save the file and run LS-Updater then click on the icon at the top right of the software window and choose debug.

Untick everything on the left of the dialogue and tick only "do not check version", "rebuild partition table" and "force update"

Like in this link:

Then run the update and let it run for a while. It will take some time to rebuild the tables.

It will give an error or time out near the end of the process. Don't worry... just flick the switch on the back of the NAS to off and wait for it to shut down (up to 10 mins), then flick the switch to ON (not Auto) and wait until it fully reboots. The orange light may appear, but will turn to a steady blue light after 5 mins

Refresh your NAS navigator when the steady blue light appears, and change the NAS IP to pick up your network *DHCP

*config may differ if you don't use DHCP

The default username and password for the device is 'admin' and 'password'

It may tell you it can't complete the IP change, but its talking rubbish. Just unplug the cat5 that's connecting the NAS to the router at the router end and plug it into your network.

Change your PC IP to use DHCP and run NAS navigator again to see if your LS appears on your network

Run Setting for your device and notice the everything is Japanese

Login and change the language setting, blind using this link as a guide.

This took me four days to get through the CBA stage, but as soon as I got things underway, it took about 2 to 3 hours.

Prior to this unit becoming bricked, the device was giving errors that the hard drives were completely spent. I'm using the exact same hard drives and they are working perfectly after I wiped them and went through this process. I've now got a spare 4TB of storage - happy days!!


« Last Edit: July 17, 2017, 07:45:01 am by cwj73 »


  • Calf
  • *
  • Posts: 6
Re: Can not see Link Station LS-WXL on my network
« Reply #2 on: October 18, 2017, 10:18:46 am »


  • Really Big Bull
  • VIP
  • *
  • Posts: 5955
Re: Can not see Link Station LS-WXL on my network
« Reply #3 on: October 18, 2017, 10:29:01 am »

Retarded comment, how long have you had your LS-WXL? Considering it hasn't been made in roughly 5 years, i'd imagine you've had it more than a few months.

Units fail from every manufacture. I have a still using a Buffalo HD-HLAN from 2005 that is still working fine.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.