Author Topic: WZR-600DHP Revert to Buffalo encrypted firmware from community DD-WRT  (Read 7154 times)


  • Calf
  • *
  • Posts: 5
I had given up all hope of Buffalo providing an updated firmware for the WZR-600DHP and was sick of getting wifi drops from the last stable version released. So i had moved on to the community build of DD-WRT. But just now, SHOCKINGLY, i saw that Buffalo had released wzr600dhp-pro-v3.0-r30355.enc  based on build r30355. Is there any hope of reverting to the Buffalo supplied encrypted firmware (.enc) from the standard Community DD-WRT? I have not successfully gotten any TFTP procedures to work, from either a Windows XP or OS X machine trying the techniques discussed on DD-WRT's wiki for recovering from a bad flash.


  • Calf
  • *
  • Posts: 5
Re: WZR-600DHP Revert to Buffalo encrypted firmware from community DD-WRT
« Reply #1 on: January 08, 2017, 12:33:55 am »
So i'll answer my own question, since there is so much conflicting and misinformation out there.

  • Ensure Router h/w switch on the back of the unit is set to ON, not AUTO.
  • Put a hardware ethernet switch between computer & the router (otherwise Mac & Windows computers can miss the TFTP window waiting for the Buffalo's onboard hardware switch to become active). Plugged into switch port 1, not WAN.
  • Setting your computer to a static IP:, mask, gatway
  • Download Professional-v24sp2-20180a.enc file to your home directory. 
           (Started with that, the factory default DD-WRT firmware version, since it is smaller than the current build)
  • open command line (Mac
  • issue arp -s 02:aa:bb:cc:dd:20 (yes, exactly as shown a dummy MAC for this specific model; this was the key step i had been trying the hardware MAC address of the router 10:6F:3F:E8:XX:XX; which didn't work. During the diagnostic phase of bootup, apparently it responds to this canned MAC address, not what you would otherwise expect.)
  • Now with the switch connected to the computer and router...set the following command...but don't hit enter yet:
Code: [Select]
$ tftp
tftp> binary
tftp> rexmt 1
tftp> timeout 60
tftp> trace
Packet tracing on.
tftp> put Professional-v24sp2-20180a.enc
  • Plug in router...wait until you just see the switch LEDs come on for the router and hit ENTER. (~10 Seconds)
    Timing is very tricky here.  When the switch LED's blink in unison it is takes about 15 will respond with success message and the Red DIAG led will blink...then go out when the unit reboots. Wait 10 to 15 minutes before trying to access the unit.
  • Clear the arp cache so you can access the router via the ACTUAL MAC address once it has booted: sudo arp -d ifscope en0
  • Load the router at the default address:, using the default login info u: admin p:password
Cancel out of the setup wizard for now, but change the default login credentials. Now you can upgrade to the latest Buffalo-supplied wzr600dhp-pro-v3.0-r30355.enc firmware version.
« Last Edit: January 08, 2017, 12:42:42 am by gatorparrots »


  • Calf
  • *
  • Posts: 2
Re: WZR-600DHP Revert to Buffalo encrypted firmware from community DD-WRT
« Reply #2 on: February 20, 2017, 07:05:27 pm »
You know the latest firmware gave me a response improvement. I was running Pro-v24sp2 20180b. I was trying to find the latest and your post lead me to that - so thanks. Apparently the "check for updates" in the GUI doesn't work, as it was not showing pro-v3.0


  • Calf
  • *
  • Posts: 1
Re: WZR-600DHP Revert to Buffalo encrypted firmware from community DD-WRT
« Reply #3 on: March 29, 2017, 11:56:33 am »
I'm trying the steps gatorparrot has provided -- I just don't seem to have the timing right with my WZR-600DHP.  I've tried both with the dummy MAC (02-aa-bb-cc-dd-20) as well as the device's actual MAC.

From power-on of the router, all the LEDs flash at about 6 seconds in; then it's another 20 seconds or so before the wireless connection LEDs turn on.  The instructions state the connection LEDS should start at about 10seconds.   I've tried starting TFTP at 6 seconds, at 10 seconds, at 25 seconds, etc.  In each case the transmission over TFTP doesn't work (it times out).

Also have tried Pumpkin TFTP, the linksys TFTP.exe and TFTP2.exe programs, all without success.

Just as background for what I'm trying to do: I have Buffalo latest r30355 installed, which doesn't seem to offer a repeater bridge mode (it does not appear in the wireless mode drop-down).  I'm trying to switch to community DD-WRT so I can use this router as a wireless bridge...

I've been at this several hours and can't seem to hit it right.  Any other ideas out there?


  • Tatanka
  • **
  • Posts: 66
  • Bringin the DD-WRT.
Re: WZR-600DHP Revert to Buffalo encrypted firmware from community DD-WRT
« Reply #4 on: April 12, 2017, 05:01:29 pm »
There's a community release almost 1500 revisions newer than the buffalo for the V1 WZR-600DHP here:

For the V2 WZR-600DHP it's here:

I've only used this revision via the 1750DHP on the US, RU and UK/EU routers i own. So can't be 600DHP specific; but the issues with bridges and repeaters seem resolved...

If moving from Buffalo, use the factory-dd-wrt-NEW version
If moving from DD-WRT community the web-flash should be OK (If not try again with the factory-NEW)

Whatever you do select "Reset to Factory Defaults" (Or similar) when updating the router otherwise chaos will ensue (and maybe a bricked router). This is generally good practice when updating anyway; for the sake of some pencil and paper time...

Also consider a 30/30/30 reset before doing ANYTHING with updates; it's not necessary all the time but may eliminate some issues with some versions of the router before doing an update and risking a brick...


  • Calf
  • *
  • Posts: 2
So I am running wzr600dhp-pro-v3.0-r30355. This is supposed to be Buffalo's flavor community build right? I would like to move to a later release of the community build. When trying to do the Web Firmware upgrade it says 'update failed'. I'm trying to load buffalo_to_ddwrt_webflash-MULTI.bin.

I read that Buffalo has something in their firmware that prevents loading of other community builds. If that is true, what sell these as DD-WRT compatible routers???

So I then tried the TFTP thing for a couple of hours and nothing. I did both the special Arp MAC and the device MAC. I've tried all the timing and resetting. Nothing. Read the Wiki, forms, tried all posted items - I never see the tftp client take. The router boots into normal mode. I've done power cycles and hard resets. Just nothing.

So why is it so hard to upgrade a DD-WRT compatible router to DD-WRT??