Author Topic: NFS error  (Read 2292 times)

zurvan

  • Calf
  • *
  • Posts: 1
NFS error
« on: June 17, 2009, 12:46:50 pm »
   

Hi I have a TS-HTGL/R5 running firmware version 1.33.  I have enabled NFS on the TS-HTGL/R5 server, and set the network address to the entire subnet (eg 192.168.2.0), and set the subnet to 255.255.255.0.  I am trying to mount these shares on to a Debian 5.0 server.  Each time I, as root, attempt to mount the nfs share I get "mount.nfs: 192.168.2.200:/mnt/arry1/project_bak failed, reason given by server: Permission denied". I have tried to registering the client (server 192.168.2.3) and that did not change the results.  Is there something else I need to check/change?

 

-- Blair


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: NFS error
« Reply #1 on: June 18, 2009, 04:08:00 pm »

Make sure the share is enabled for NFS in NFS Folders Setup and set the NFS network address to the IP of the Terastation.

 

 NOTE: for the Terastation Pro II, the NFS network address needs to be set to the IP of the Terastation. For the Terastation III, it needs to be set to the base subnet address.


KJSTech

  • Calf
  • *
  • Posts: 3
Re: NFS error
« Reply #2 on: February 07, 2013, 11:22:00 am »

Hi, has anyone been able to enable NFS on one of these so a VMWare ESX 4.1 host can add it as a datastore?

 

my vmkernel logs say Failed to mount the server 10.1.1.21 mount point /mnt/array1/backups.  Unable to connect to NFS server.


I also tried mapping it to the folder name /backups.  Either it or the full path with /mnt/array1 ... doesn't work.

 

The terastation's IP (Same IP I use to get to it's web gui) and Subnet are in the NFS ip.  For clients the IP address of the VMWare ESX 4.1 host is setup.  For the folders the shared folder name 'backups' is checked off (shows unchangeable nfs path of /mnt/array1/backups.

 

TS-RHTGL/R5

I applied the firmware called 1.35 - 1.39 and the web gui says its 1.35.