Author Topic: WebAccess only working locally - SOLVED  (Read 6266 times)

jbozic

  • Calf
  • *
  • Posts: 18
WebAccess only working locally - SOLVED
« on: September 30, 2016, 03:29:43 am »
Dear all,

please help us find a solution for using WebAccess from other coputers outside the network & on iPhone app Web Access.

We've set up the Buffalo nas (LX-WXL4), we're using firmare 1.71, we've forward port 9000 and enable UpNP on router (TP-LINK).

When we connect to buffalonas.com/ and enter our domain name, then login w/ the password, we can see the shared folders on NAS.
But when we try to access it from mobile internet, or from home, the url is not working.

Thank you and kind regards.
« Last Edit: October 24, 2016, 06:48:00 am by jbozic »

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5926
Re: WebAccess only working locally
« Reply #1 on: October 02, 2016, 07:09:09 am »
If it's working locally but not remotely then the port isn't open.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #2 on: October 03, 2016, 02:01:53 am »
Hi,

we have a TP-LINK router, and on Forwarding > Virtual Servers I've set up:
- Service Port: 9000
- IP Address: 192.168.1.XXX (XXX is the IP of NAS)
- Protocol: All
- Status: Enabled
- Common Service Port: --Select One--

Is there something I did wrong?

TY, BR.

Texturtle

  • Administrator
  • *****
  • Posts: 802
  • RAID is NOT a substitute for a good backup
Re: WebAccess only working locally
« Reply #3 on: October 03, 2016, 12:09:12 pm »
There is an external port and an internal port, these may not be the same. Verify that the external port you're using is actually opened by your ISP. You can use canyouseeme.org to check if the port is open.

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #4 on: October 05, 2016, 03:25:48 am »
Hi,

I have opened port 32804 (external) also.
I've opened this one under Forwarding > Virtual Servers (same as port 9000).
- Service Port: 32804
- IP Address: 192.168.1.XXX (XXX is the IP of NAS)
- Protocol: All
- Status: Enabled
- Common Service Port: --Select One--

Should I've done that under Port Triggering?
DMZ in disabled on TP-LINK & UPnP enabled.

Also I have to set HTTPS/SSL Encryption to Enable to get it working locally on my iPhone.

Please advise if there is another parameter I should set up in Virtual Servers or somewhere else?!

Thank you, best regards.
« Last Edit: October 05, 2016, 03:32:16 am by jbozic »

Texturtle

  • Administrator
  • *****
  • Posts: 802
  • RAID is NOT a substitute for a good backup
Re: WebAccess only working locally
« Reply #5 on: October 05, 2016, 11:10:05 am »
Have you verified that port 32804 is opened by the ISP?

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #6 on: October 11, 2016, 06:04:02 am »
Have you verified that port 32804 is opened by the ISP?

Hi,

I've called the ISP & they are claiming that the port is open from their side.



But I'm still getting error on canyouseeme.org (32804)

Please help.

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5926
Re: WebAccess only working locally
« Reply #7 on: October 11, 2016, 06:19:08 am »
If you are getting an error on canyouseeme.org then the port is not open. You might be double natting.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #8 on: October 11, 2016, 06:25:03 am »
If you are getting an error on canyouseeme.org then the port is not open. You might be double natting.

Hi,

I was calling them 3 days straight & now they return the call that everything is open by them.

Maybe I'm making a mistake somewhere?
IP for opening port is from NAS (.119), not our IP?

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #9 on: October 21, 2016, 05:31:26 am »
Hi,

still having problems with opening external port (32804) of the NAS.

It's 100% opened from ISP.
It's open on rounter (picture in previous post).
It's open in inbound & outbound firewall settings.

Please advise, where else can I check or change the parameters to get buffalo web access working?!

Thank you and kind regards.

Texturtle

  • Administrator
  • *****
  • Posts: 802
  • RAID is NOT a substitute for a good backup
Re: WebAccess only working locally
« Reply #10 on: October 21, 2016, 09:30:59 am »
I'm not sure about the settings on the router, but it needs to be forwarding traffic coming in on port 32804 the NAS IP on port 9000. From that screen, it doesn't look like it's doing that. It looks like it doesn't change ports between the external and internal traffic.

That would mean that traffic coming in through port 32804 is being sent to the NAS on port 32804. The NAS, however, is expecting WebAccess traffic to be on port 9000 so it ignores traffic on port 32804.

Being unfamiliar with the TP-Link interface I'm afraid I can't advise you on how to configure the router to do what it needs to do. I've set this up on several different manufacturers routers without a problem but not on this model.

Looking at the manual for that router, it appears that they are using the term port triggering to describe what you need to do. Try setting this up under port triggering rather than virtual servers.

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #11 on: October 24, 2016, 03:15:18 am »
Thanks for reply ... Still w/o success.
We'll try to contact TP-Link service also.

BR.

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5926
Re: WebAccess only working locally
« Reply #12 on: October 24, 2016, 05:31:47 am »
Looking at the TP link settings you have 2 separate port forwarding rules setup, not one.

You need to forward the external port to the internal port in one rule. Not sure if your router is capable of doing this. If not then change the internal and external ports on the web access setup to 9000 (disable UPnP) and then just forward port 9000 in one rule.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

jbozic

  • Calf
  • *
  • Posts: 18
Re: WebAccess only working locally
« Reply #13 on: October 24, 2016, 05:56:04 am »
Looking at the TP link settings you have 2 separate port forwarding rules setup, not one.

You need to forward the external port to the internal port in one rule. Not sure if your router is capable of doing this. If not then change the internal and external ports on the web access setup to 9000 (disable UPnP) and then just forward port 9000 in one rule.

Hi Davo,

probably I didn't understand, but if you mean settings like from pictures below, it's still not working.
But it takes longer to error - timed out from my phone to access WebAccess.

If there is something I should change in the settings, please advise.




Thanks, best regards.
« Last Edit: October 24, 2016, 06:45:53 am by jbozic »

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5926
Re: WebAccess only working locally
« Reply #14 on: October 24, 2016, 06:29:42 am »
I just checked your Buffalonas.com and can connect to it without issues.
« Last Edit: October 24, 2016, 06:48:03 am by davo »
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.