Author Topic: WHR-300HP2D failures after bad update  (Read 1359 times)

dlublink

  • Calf
  • *
  • Posts: 1
WHR-300HP2D failures after bad update
« on: August 24, 2016, 12:46:15 pm »
Hello,

I have a lot of WHR-300HP2D devices. When doing updates, 12 of them crashed during update and now they won't boot. I plug them in, the power light comes on but the diagnostic light did not come on.

I tried downloading doing TFTP recovery ( arp -s <ip> <mac> ) put 192.168.11.1 ( similar to this page http://g300nh.blogspot.ca/2010/06/firmware-flash-and-brick-recovery.html ), but using the appropriate firmware for the WHR-300HP2D device.

I never get any reply from the router, I only see this in tcpdump :

13:27:40.203534 IP (tos 0x0, ttl 64, id 8290, offset 0, flags [DF], proto UDP (17), length 64)
    192.168.11.2.41418 > 192.168.11.1.69: [bad udp cksum 0x9791 -> 0x527c!]  36 WRQ "whr300hp2d-v24sp2-30353.bin octet

I never see replies from the device.

I tried various combinations of using the reset button ( 30-30-30 reset, hold 30 seconds on boot, hold 10 seconds on boot, hold 5 seconds, etc... )

I found a site suggesting a 'secret' mac address on the devices, it said I should try 02:AA:BB:CC:DD:?? where ?? is a different number for each device. So I ran a seq from 00 through FF ( without rebooting the router ), and tried each mac with TFTP and still no reply.

TFTP is set to retry after 1 second.

I tried different power supplies, both new and used. I used 12v / 1A / Positive contact is middle contact.

I found a website that spoke about JTAG connections, but that would void my warranty, which would be unfortunate.

The routers have always run 'official' buffalo firmware ( as in the firmware from Buffalo, it's basically DD-WRT with blue changed for red, and dd-wrt replaced with 'Buffalo DD-WRT' ).

Where can I go from here? Most of the devices are still under warranty, but returning 12 routers on warranty seems like a lot of hassle. Anyone have any idea how I can fix these routers without voiding my warranty?


Thanks!

dlublink