Author Topic: LS-CH500L - E22 - Cannot mount drive, but how do i get.....  (Read 5300 times)

Snickolls

  • Calf
  • *
  • Posts: 10
LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« on: January 31, 2011, 04:07:51 am »

Morning all,
Had my Linkstation for 2 weeks, set it up to act as a temp storage area while i shift things around on a few of my machines in work....  Firmware is 1.34
Friday:  Moved 100gb worth of data/setup files, etc etc...

Monday Morning:
I have the E22 - Fails disk1 mount !!!!!!!!!!!!!!!!!
Have read other peoples posts on here, and would appear thats a pretty bad sign, and not somthing you would expect after 2 weeks given its brand new!
I've emailed tech support so just need to wait a week to get a reply, in the meantime, is there anything i can do to get the data off that drive ?

 

If i open the unit, am guessing i void the warranty ? given the device is so new, would sending it to Buffalo Tech in Bracknell (UK) and asking them to get my data off and put onto a new device, would this work ?
Obtaining my data is far more important than just having the single HDD swapped out..
Cheers


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #1 on: January 31, 2011, 08:15:09 am »

If you need your data you should be able to get an advanced replacement and swap the hard drives in the unit yourself to get back to your data. They will not recover your data for you or swap the drives for you. 


Snickolls

  • Calf
  • *
  • Posts: 10
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #2 on: January 31, 2011, 09:39:47 am »

Can you elaborate on the advanced replacement ? i dont follow........
Am good for swapping out drives, but as said, dont want to void any warranty by taking the HDD out unless told to do so ?


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #3 on: January 31, 2011, 10:15:35 am »

Just call up your local support, tell them your problem and see if they can set you up for an advanced replacement and get permission to swap drives for data recovery. The advanced replacement option lets you get a unit first from buffalo swap your drives and send them back your old unit with the new drive. 


Snickolls

  • Calf
  • *
  • Posts: 10
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #4 on: January 31, 2011, 10:18:16 am »

ok, sounds a plan :) :)  cheers for advice...


So in theory, my data is safe, as such, i just either need another linkstation to see the data, or need to connect it to a PC and use a data recovery tool which can see that drive (cant imagine it being FAT32 ?)


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #5 on: January 31, 2011, 11:49:02 am »

No, its XFS. Now there still maybe in an issue with the drive. The E22 can either be a bad connection on the motherboard or a bad hard drive. The only way to know is to test. 


Snickolls

  • Calf
  • *
  • Posts: 10
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #6 on: February 03, 2011, 04:55:52 am »

The support people replied with this:

If the HDD is taken out, then the warranty is void...

 

Was also advised not to store any data on the linkstation ?

how nice ? Reason i bought it was for that!  Why else would you buy a NAS box ?????????

 

I accept things die eventually, but this device has been running for 2 weeks. 
Basically i've been told 'tough' when it comes to data !!


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #7 on: February 03, 2011, 06:27:06 am »

Which support line did you call?


Snickolls

  • Calf
  • *
  • Posts: 10
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #8 on: February 03, 2011, 10:05:19 am »

I rang the UK one.....
Bloke i spoke to on the phone said the same as what was said to me in the email, which translates to:

If you store data on your linkstation, you should also keep a backup elsewhere.

 

The supplier i ordered from will exchange the drive, but i need my data from there first....
So now i need to waste this unit and get it open to get the drive out.... 

And low and behold, the non-helpful support staff wont tell me how to open the unit despite me saying i'm happy to lose the £77 i paid for this device so i can open it to get my data off (i've already cancelled the 43 of them ordered with my supplier for our home based workers)....

 

Dont want to cut into the plastic just in case i damage the drive ? 


Ji

  • Calf
  • *
  • Posts: 1
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #9 on: April 19, 2011, 01:52:11 am »

I got the same error E22 after using my LS-XH2.0TL for over a year.  Since the product is already out of warranty, I decided to find out what went wrong.  What surprised me is that it turned out to be software error and the problem can be fixed.  Here is what I did:

1) Open the case and remove the SATA drive and put it into my PC that supports the SATA. (*)

2) Burn a Linux system rescue CD.  Here is the URL: http://www.sysresccd.org/Main_Page Because the file system on the drive is XFS, you need to boot into a Linux system to see or fix the file system.

3) Once I booted into rescue CD on my PC, I tried to mount the file system on that drive.  The device is recognized by the Linux as /dev/sda (that's the only drive I put in my PC for this rescue).  Using gparted, it shows that /dev/sda has 6 partitions, the main data partition is the largest, and it is /dev/sda5.

4) I tried to mount /dev/sda5, and got the error message "Structure needs cleaning".  This is exactly the reason why the LinkStation can't mount the file system in my case.

5)  I then followed the instruction on http://xfs.org/index.php/XFS_FAQ#Q:_I_see_applications_returning_error_990_or_.22Structure_needs_cleaning.22.2C_what_is_wrong.3F

First using xfs_check to confirm there is problem for the file system, and then used xfs_repair to fix the device (with -L option).

6) Then I was able to mount /dev/sda5 on my PC.

7) After that, I put the drive back to the LinkStation device, everything is back to work.

 

(*) To open the case, you need to remove labels at the buttom, and insert flat head screw drivers into the two small openings and insert pins on the top the help open the case. 

 

I think I may get this problem again in the future when the XFS meta data is out of sync again...

 

Hope it helps to those whose products are out of warranty and need to rescue data.

 

Ji


Jotin

  • Big Bull
  • *****
  • Posts: 4201
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #10 on: April 21, 2011, 01:58:09 pm »

Thanks Ji, thats a really good post. I'll pass it on to other people. 


golaabi

  • Calf
  • *
  • Posts: 2
Re: LS-CH500L - E22 - Cannot mount drive, but how do i get.....
« Reply #11 on: August 29, 2015, 08:37:17 am »
Ji's solution worked for me. thanks