Author Topic: MiniStation Not Appearing When Plugged In  (Read 2680 times)


  • Calf
  • *
  • Posts: 2
MiniStation Not Appearing When Plugged In
« on: June 24, 2015, 09:52:37 pm »
I have an HD-PCF MiniStation external hard drive that I have been using with a MacBook Air running OS X Yosemite. The device was working properly and then I believe it was accidentally disconnected without clicking "eject" first on the computer. Now, when I plug the hard drive into the computer, the green light on the device turns on but it is not recognized by the computer and I cannot access the contents of the device. I have tried it with multiple USB ports on my computer and have tried it with another Mac laptop and the hard drive is not recognized anywhere. I tried Apple support and they said there is probably an issue with the hard drive since it doesn't work with multiple accounts, computers and USB ports. Does anyone have any ideas to help?  Thanks!


  • Really Big Bull
  • VIP
  • *
  • Posts: 5961
Re: MiniStation Not Appearing When Plugged In
« Reply #1 on: July 29, 2015, 09:20:45 am »
Does it appear in disk utility?
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.