Author Topic: Buffalo NAS on a Uverse NVG589 Modem/Router  (Read 3896 times)

Ron Bess

  • Calf
  • *
  • Posts: 1
Buffalo NAS on a Uverse NVG589 Modem/Router
« on: March 31, 2015, 12:29:26 pm »

Let me start with, I am not a network guy. A little technical but in a completely different field and this has frustrated me to no end. I had my Buffalo LS410 NAS working perfectly on TWC over my ASUS N56 router but TWC couldn't resolve their DTV signal issues so we changed to Uverse. Fantastic TV experience but now I cannot figure out how to get to my NAS from work or my Buffalo App on my phones anymore.
I've read these forums and obviously not getting it and every time I try something, I come really close to screwing it all up. My wife has about had it with me trying and I will attempt to get help from an ATT tech if needed but wanted it to be a last resort. I'd prefer to learn something. I just want my NAS back. I apologize in advance for asking for help on something that has probably already been explained but hoping that someone out there can be very specific for a BuffaloNAS and be able to provide steps that even a newbee can understand. I'm not opposed to some kind of bridging directions for the ASUS as long as the ATT equipment currently attached to the NVG589 LAN ports continue to work.
I have one DVR on a LAN port and Wireless Transmitter to the receiver in the living room TV. 2 tablets, 2 phones and 1 wireless printer.
The Buffalo Web Interface settings says that it needs a UnPn (which worked on my ASUS) or Port 9000.  I've tried activating IP Throughput, I've tried Adding a custom Device to the NAT/Gaming. Nothing works for me. Surely I can't be the only person in the world trying to reach my NAS using Uverse.
Thanks in advance.


  • Administrator
  • *****
  • Posts: 834
  • RAID is NOT a substitute for a good backup
Re: Buffalo NAS on a Uverse NVG589 Modem/Router
« Reply #1 on: April 01, 2015, 11:45:48 am »
It may be that the external TCP port you're using is being blocked by AT&T.

Try following this guide: